Paste from system clipboard doesn't work

Help
2013-01-07
2013-05-29
  • David Miller

    David Miller - 2013-01-07

    In 2.8.2p4 on Mountain Lion…  If I copy image or text data from another OS X application (such as GraphicConverter or Firefox) and try to paste it into GIMP, I get a small white box instead of whatever I actually tried to paste.

     
  • Thomas Tempelmann

    I am seeing a similar problem with 2.8.4's default install, on both 10.7.5 and 10.8.3: Any graphics I copy in other programs such as TextEdit and Preview can't be pasted into GIMP at all. GIMP instead seems to keep its own private Clipboard instead of using the system-wide clipboard, pasting whatever I copied last in GIMP, not what I copied in another application.
    That's quite the bug, and I've seen similar reports back in 2009 (http://sourceforge.net/p/gimponosx/discussion/761056/thread/08fd3443) - there, people suggested to change X11 prefs that control the synching of the system clipboard. We don't seem to have this option in X11-less 2.84 any more, do we?

     
  • Simone Karin Lehmann

    hhmm, have you tried my version of GIMP from http://gimp.lisanet.de ? (sorry, that there are now two GIMP builds. the so callad 'official' one, which is very basic, and mine, which integrates better into OS X, fixes some OS X bugs, inlcudes Python and many plugins....)

    AFAICS my build works as expected. I can open an image in Preview, copy that image with CMD + A and CMD + C and then paste it into GIMP by CMD + V

    Please download a version from http://gimp.lisanet.de and give it a try.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks