Cant open GIMP on Mac OS X 10.6.8

Help
Anonymous
2011-07-09
2013-05-15
  • Anonymous

    Anonymous - 2011-07-09

    I installed Xquartz vesrion 2.6.2 and install Gimp 2.6.11 for Snow Leopard from http://gimp.lisanet.de/ but after launch Xquartz, Gimp don't open…

    Please find below the console information :

    09/07/11 11:20:25 .org.macosforge.xquartz.X11 X11.app: main(): argc=2
    09/07/11 11:20:25 .org.macosforge.xquartz.X11 argv = /Applications/Utilities/XQuartz.app/Contents/MacOS/X11.bin
    09/07/11 11:20:25 .org.macosforge.xquartz.X11 argv = -psn_0_618647
    09/07/11 11:20:25 .org.macosforge.xquartz.X11 X11.app: Could not connect to server (DISPLAY is not set).  Starting X server.
    09/07/11 11:20:25 .org.macosforge.xquartz.X11 Waiting for startup parameters via Mach IPC.
    09/07/11 11:20:25 .org.macosforge.xquartz.X11 X11.app: Launching /opt/X11/bin/startx:
    09/07/11 11:20:25 .org.macosforge.xquartz.X11 argv = /bin/sh
    09/07/11 11:20:25 .org.macosforge.xquartz.X11 argv = -c
    09/07/11 11:20:25 .org.macosforge.xquartz.X11 argv = /opt/X11/bin/startx
    09/07/11 11:20:25 .org.macosforge.xquartz.X11 font_cache: Scanning user font directories to generate X11 font caches
    09/07/11 11:20:25 .org.macosforge.xquartz.X11 font_cache: Updating FC cache
    09/07/11 11:20:25 org.macosforge.xquartz.privileged_startx font_cache: Scanning system font directories to generate X11 font caches
    09/07/11 11:20:25 defaults
    The domain/default pair of (org.macosforge.xquartz.X11, dpi) does not exist
    09/07/11 11:20:26 .org.macosforge.xquartz.X11 xauth:  file /Users/sam/.serverauth.2443 does not exist
    09/07/11 11:20:26 .org.macosforge.xquartz.X11 launch_msg("CheckIn") IPC failure: Operation not permitted
    09/07/11 11:20:26 .org.macosforge.xquartz.X11 X11.app: No launchd socket handed off, unsetting DISPLAY
    09/07/11 11:20:26 .org.macosforge.xquartz.X11 X11.app: do_start_x11_server(): argc=6
    09/07/11 11:20:26 .org.macosforge.xquartz.X11 argv = /opt/X11/bin/X
    09/07/11 11:20:26 .org.macosforge.xquartz.X11 argv = :0
    09/07/11 11:20:26 .org.macosforge.xquartz.X11 argv = -nolisten
    09/07/11 11:20:26 .org.macosforge.xquartz.X11 argv = tcp
    09/07/11 11:20:26 .org.macosforge.xquartz.X11 argv = -auth
    09/07/11 11:20:26 .org.macosforge.xquartz.X11 argv = /Users/sam/.serverauth.2443
    09/07/11 11:20:26 .org.macosforge.xquartz.X11 Xquartz starting:
    09/07/11 11:20:26 .org.macosforge.xquartz.X11 X.Org X Server 1.10.1
    09/07/11 11:20:26 .org.macosforge.xquartz.X11 Build Date: 20110429
    09/07/11 11:20:26 org.macosforge.xquartz.privileged_startx font_cache: Updating FC cache
    09/07/11 11:20:26 .org.macosforge.xquartz.X11 X11.app: DarwinProcessFDAdditionQueue_thread: Sleeping to allow xinitrc to catchup.
    09/07/11 11:20:26 .org.macosforge.xquartz.X11 (EE) Error loading keymap /tmp/server-0.xkm
    09/07/11 11:20:26 .org.macosforge.xquartz.X11 (EE) XKB: Failed to load keymap. Loading default keymap instead.
    09/07/11 11:20:27 .org.macosforge.xquartz.X11 font_cache: Done
    09/07/11 11:20:28 .org.macosforge.xquartz.X11 /opt/X11/bin/xinit: XFree86_VT property unexpectedly has 0 items instead of 1
    09/07/11 11:20:28 org.macosforge.xquartz.privileged_startx font_cache: Done
    09/07/11 11:21:44 .org.gimp.Gimp find: /Users/sam/Library/Application Support/Gimp/help: No such file or directory
    09/07/11 11:21:44 defaults
    The domain/default pair of (org.x.X11, dpi) does not exist
    09/07/11 11:21:44 .org.gimp.Gimp 2011-07-09 11:21:44.213 defaults
    09/07/11 11:21:44 .org.gimp.Gimp The domain/default pair of (org.x.X11, dpi) does not exist
    09/07/11 11:21:44 .org.gimp.Gimp dyld: Library not loaded: /usr/X11/lib/libXrandr.2.dylib
    09/07/11 11:21:44 .org.gimp.Gimp   Referenced from: /tmp/skl/Gimp.app/Contents/Resources/lib/libgtk-x11-2.0.0.dylib
    09/07/11 11:21:44 .org.gimp.Gimp   Reason: Incompatible library version: libgtk-x11-2.0.0.dylib requires version 5.0.0 or later, but libXrandr.2.dylib provides version 3.0.0
    09/07/11 11:21:44 .org.gimp.Gimp /tmp/skl/Gimp.app/Contents/Resources/bin/gimp: line 11:  2621 Trace/BPT trap          gimp-2.6 "$@"
    09/07/11 11:21:44 ReportCrash Saved crash report for gimp-2.6 version ??? (???) to /Users/sam/Library/Logs/DiagnosticReports/gimp-2.6_2011-07-09-112144_iMac-de-sam.crash

    Thanks in advance for your help

     
  • Simone Karin Lehmann

    … so once again the same answer:

    - Please read the file "Important notes.rtf", which is included in the dmg you've donwloaded,

    or read the various pages and notes all over my website, e.g.

    the Download page:  http://gimp.lisanet.de/Website/Download.html

    X11:
    Mac OS X 10.5 Leopard and 10.6 SnowLeopard are shipped with X11. There‘s no need to install any other X11 package nor XQuartz.

    the Support page:  http://gimp.lisanet.de/Website/Support.html

    On Snow Leopard and on Leopard systems, X11 is installed by default on every system. It‘s located in the „/Applications/Utilities“ folder. If you don't have X11 installed …  then just install X11. It's on your Installation DVD in the "Optional Installs" folder.

    the main GiMP site (if you visit them via a Mac / Safari) : http://www.gimp.org/downloads

    … install GIMP 2.6 easily on the Mac using the packages provided by GIMP on OS X.  … …
    Running GIMP on Mac OS X requires Apple's X11 environment. It is included on the "Optional Installs" package on the OS X install disk.

    So,

    do _not_ use XQuartz. Never. It won't work. Use Apple's X11. It's on your SL Installation DVD

    And BTW, could anybody please tell me, why it is so difficult to read a file called "Important notes.rtf" or read any other note I've written? What should I do do make people read this? On how many places should I write "Please use Apple's X11"?

    For all of you who want to know why there is a difference between Apple's X11 and XQuartz, please read the 3. posting in this thread:

    https://sourceforge.net/projects/gimponosx/forums/forum/761055/topic/4509200

     
  • malibunerd

    malibunerd - 2012-07-01

    I am using a Macbook running on Snow Leopard and I have installed X11 from my Software CD and I have installed Gimp as well. Gimp does not open and asks the user to install Xquartz. Upon clicking the Download and Install option, the "This Site Does Not Exist" screen opens. I am unable to use Gimp. I have read the "Important Notes" file and it has not provided much help. I would like to know if there is any way to access Gimp and why it is not opening. Thank You.

     
  • Simone Karin Lehmann

    I've just tested the packages. The "Download and Install" works as it should. It opens a Terminal.app window and downloads XQuartz and then launches the Installation dialog of XQuartz. Sorry. I can' reproduce yout issue.

    Try downloading XQuartz (get the 2.7.2 version) directly from

    http://xquartz.macosforge.org/trac/wiki/Releases

    and install it. Then log out and log in again and the launch GIMP.

     

Log in to post a comment.