Help Files Not Working

1 2 3 > >> (Page 1 of 3)
  • Lonny Eachus

    Lonny Eachus - 2012-05-13

    Completely aside from the fact that GIMP apparently confuses the concept of a User Manual with that of Help Files, the fact is that the "User Manual" on the GIMP on OS X download page (manual v 2.6) isn't working with GIMP 2.8.

    I am on OS X Lion (10.7.4), I have the latest XQuartz (2.7.1) and I have installed. I downloaded the "User Manual" today, unzipped the package, ran it… twice. The install package runs to completion and says it was successful. Yet when I start up GIMP, and try to go to Help, I get the Web Page saying "Eeek!  GIMP help files are not installed."

    Is anybody else having this issue?

  • Lonny Eachus

    Lonny Eachus - 2012-05-13

    Clarification: I went into Preferences | Help System and set "Help Browser" to "GIMP Help Browser" rather than "Web Browser", to see if that would solve the issue. The window says there is a locally installed copy of the "User Manual", by the way.

    That did not fix the issue. When I press F1 I get a popup saying "The GIMP Help Browser is not available. … The GIMP help browser plug-in appears to be missing from your installation."

    And I get the same message when I click on something under Help | User Manual, even though Preferences tells me that there is a local copy of the user manual installed.

  • Simone Karin Lehmann

    the fact is that the "User Manual" on the GIMP on OS X download page (manual v 2.6) isn't working with GIMP 2.8.

    yes, I've disabled the use of the 2.6 manual in GIMP 2.8.0. That's just because the manual is for 2.6 and not for 2.8 ;)

    And, please be patient. I'm the only one working on GIMP on OS X and in the last few days I didn't have time to build some 2.8 user manual package. I've just decided to first make 2.8 available for Mac OS X. And then, I will build some user manual packages. Until then, either user the menu "Help -> Gimp Online" or copy the old 2.6 files to the new 2.8 location. To do this,

    a) go to '/Users/Shared' and make sure that a folder 'Gimp' exists. If not, create it. Go into the 'Gimp' folder an create a new folder named 'help'.
    b) go to your user Library  '~/Library/Application Support/Gimp/help'. There you'll find a folder named like your country code, e.g. 'en' for 'english'.
    c) copy the 'country-code-folder' to '/Users/Shared/Gimp/help'


    be patient and wait unit I'll release new packages for 2.8 user manuals.

  • Simone Karin Lehmann

    … and please set the Preferences to 'Web browser'. I haven't build the GIMP help browser.

  • Anonymous - 2012-05-17

    Thanks lisanet. I'm a newbie to Gimp and am looking for more help and support…which forums would you suggest?

  • ramuntcho

    ramuntcho - 2012-05-20

    Hi, Lisanet,

    I'm preparing these. days our master in Snow Leopard and Lion, master which will be used for deployment in schools for next year. Do you think its better to set the Preferences to 'Web browser', or do you think that in2 or 3 weeks you will have the time to propose help manual (in french !) ?

    :-))  Christian

  • Sharon Bond

    Sharon Bond - 2012-07-02

    Hi Lisanet,

    Thank you for all you are doing to make GIMP available on the Mac; its capabilities are just what I need right now, when my budget for software is "zero."

    I tried to follow your instructions for loading the 2.6 Help files into the 2.8 version, but got stumped here:

    "b) go to your user Library  '~/Library/Application Support/Gimp/help'. There you'll find a folder named like your country code, e.g. 'en' for 'english'.
    c) copy the 'country-code-folder' to '/Users/Shared/Gimp/help' "

    I installed the 2.6 help files (supposedly successfully), but the above file structure does not exist on my MacBook Pro. (Lion 10.7.4, XQuartz build).

    However, within Gimp, when I go to preferences, under files, I find a location for the help files, with a green light that I presume means all is well, but no matter what I do, I cannot access the help files. I get all the same messages as a poster upthread.

    Can you add any further clarification?

    Thank you so much!

  • Simone Karin Lehmann

    @ tarheelfan

    … well, this has nothing to do with GIMP, this is Mac OS X specific.

    On Lion your user Library folder is hidden by default. To go there, got to Finder and use the menu 'Go to' and keep the ALT key pressed, Now select the 'Library' menu item.

    Then go to 'Users/Shared' (tis is a standard OS X directory). If the folder path 'Gimp/help' doesn't exist, create it.

    @ Chrstian

    you need to set Prefernces always to 'web browser'. Otherwise the online help won't work.

    And, no, I didn't find some time to  build 2.8 help files…., sorry.

  • Simone Karin Lehmann

    However, within Gimp, when I go to preferences, under files, I find a location for the help files, with a green light that I presume means all is well, but no matter what I do, I cannot access the help files. I get all the same messages as a poster upthread.

    I've added a default ' help page' within the GIMP application bundle. This is what you see. It does not mean, that the help files are installed. The default page is just the page which tells you, that you need to download the help files packages.


  • Sharon Bond

    Sharon Bond - 2012-07-02

    All has become clear. The trick of showing the hidden files led me to the help folder you described, and I have now copied it over.

    Thank you for the speedy reply!


  • Tristan K.

    Tristan K. - 2012-07-10

    I did as described but I still get the missing manual page. I followed the brewer path to file:///tmp/skl/ and then checked the terminal with ls -la in "ls -la /Applications/" which is a symbolic link to "/tmp/skl/Gimphelp". My Manual is stored in "/Users/Shared/Gimp/help/de". It doesn't make sense. Do I miss something?

  • Simone Karin Lehmann


    My Manual is stored in "/Users/Shared/Gimp/help/de". It doesn't make sense.

    you need to install them in

    "/Users/Shared/Library/Application Support/Gimp/help/de"

    Sorry. I mixed up the various scripts I'm tcurrently testing.  :-(


  • Anonymous - 2012-07-20

    I tried to copy the files as described and it worked. But I found actually a 2.8 help at I downloaded it and used the same procedure to copy the "en" folder. It worked and now I have 2.8 instead of 2.6 help.

  • Derek

    Derek - 2012-07-25

    Hi Lisanet,

    I am still having a difficult time accessing Gimp Help Manual files even after reading these post. Still to my curiosity, I do not see the "Users/Shared" files everyone mentions even when I do select the Library option.

    These are the multiple steps I have tried…

    I. Library
      a. Directly added the files chronologically: "Users/Shared/Library/Application Support/Gimp/Help/en"
      b. Paste Help Files
      c. Nothing..

    II. Library
      a. Application Support
      b. Gimp
      c. Paste Hep Files
      d. Nothing..

    III. Library
      a. Application Support
      b. Gimp
      c. Directly added the files chronologically again: "Users/Shared/Library/Application Support/Gimp/Help/en"
      d. Nothing..

    Any help would be very appreciated. I would use the web help but I have a 5GB data cap and use only when necessary. Also every time I open Gimp an application found in the utilities called "XII". Usually xQuartz opens but for some reason this has changed. Much needed help!

  • Simone Karin Lehmann

    … you're missing the '/' in the path. It's '/Users/Shared' not 'Users/Shared'. '/' is the root directory of your hard drive.

    If you're not familiar with working in or with these paths, please be patient and wait until a I release an installer package, or use the menu 'Help -> Gimp Online'

  • Simone Karin Lehmann

    … and about X11:

    if you've installed xquartz 2.7.1 or higher, logged out and in again, everything should work. I don't know, why X11 is starting and not Xquartz. The only thing I can think of is, that you did not correctly install XQuartz, logged out and in again…

    Sorry, I'm not an expert for X11 or XQuartz.

  • Nuke

    Nuke - 2012-07-26

    OK.  I just got it working.  You will have to use the Terminal.

    Try this:

    0) Download Gimp 2.8 from site & install.  Run it once.  I think that will create all the files in /Users/youruser/Library/Application Support/Gimp
    1) Download the file from
    2) Double click to open the zip.
    3) Copy all the files in the "help" folder to /Users/youruser/Library/Application Support/Gimp/
    This will overwrite the existing help folder if you had an older version of Gimp installed.
    4) If you don't have the folder /Users/youruser/Library/Application Support/Gimp/ , then create it and copy the help folder into it.
    5) Go to the place you installed Gimp (usually /Applications/Gimp)
    6) Select Gimp and ctrl click.  This should show a menu.  Select show Package Contents.
    7) Click in the newly opened Finder window to Contents/Resources/share/gimp/2.0/
    8) Delete the help folder you find in Contents/Resources/share/gimp/2.0/
    9) Open Terminal
    10) Run this command to create a symbolic link from the help folder you copied to the Application support to the Gimp app.

    sudo ln -s /Users/username/Library/Application\ Support/Gimp/help /Applications/

    11) Type in your sudo password
    12) Close window that shows the "Package Contents"
    13) Start Gimp.
    14) Go to Preferences and select: Use Local Copy and use Web Browser.

    You should be able to open the help from the menu now.

  • Simone Karin Lehmann


    No! Don't do this!

    This will break GIMP on Mountain Lion and any installer package I'll release.

    First, Mountain Lion (GateKeeper) requires applications to be signed. If you alter the application as you do, the signature is _not_ valid any longer and GIMP won't launch. So don't alter the application bundle.

    Second, if you install the help files in your users library and place a symlink into the app bundle, no other user will access the help files unless you'll grant him access to your library folder.

    Third, any future installer package of help files will still install, but won't work.

    So, please, either be patient until I release an installer package, or use the online version. If you still want to copy the files to your local hard drive, then use the correct path. This is:

    '/Users/Shared/Library/Application Support/Gimp/help'

    and copy the country code folder into this directory.

    Finally, do _no_ alter the application bundle.

  • Nuke

    Nuke - 2012-07-27

    OK, I understand.  It's a kludge.   I've not updated to Lion yet as a number of my critical apps don't run on 10.7+ so I've not spent much time figuring out Gatekeeper etc.

    I understand the right place to put shared files is in /Users/Shared/ but I'm hoping the installer will allow single user too.

    I look forward to getting the installer to do this properly. :0)

    Thanks so much for all your hard work on building Gimp for the Mac!


  • QuattroGam3r

    QuattroGam3r - 2012-08-02

    Just as an exercise, I downloaded the Gimp 2.8 package form Macports and threw in the +manual variant.
    For anyone wanting to see what Gimp looks like on a Mac with it's own help browser working, this is it. It appears to be an x11 window and the documentation is for v2.8.
    The only things I noticed about the package so far are 1. no outline visible for brushes (makes it difficult to see placement) 2. Had to install Pro theme separately.

  • lemonphenomenon

    lemonphenomenon - 2012-08-12

    Yes, I'm having exactly the same problem. I did just what you did, with the same result. I looked in application support for the manual but it wasn't there. It looks as if other people – pinchepunk, noumena – are having the same problem. I have found the online manual really good, but it would be good to be able to download the manual too.

  • lewis smith

    lewis smith - 2012-08-12

    This is a safe & effective workaround: download the entire relevant language Gimp 2.8 manual heirarchy e.g.
    Using CocoaWget (recursive, stay in same directory, level=4) works fine. Using wget directly at the command line is trickier because of all the options it offers. It takes a long time to download and then adjust for local viewing.
    Find the 'index.html' file in the created directory heirachy (which you can put where you like )- in the directory cited for download -, and create a shortcut for it e.g. on the Dock (right hand end).
    You can then peruse the manual in a browser independantly of, or while using Gimp e.g. on a separate desktop.

    Lewis Smith

  • Simone Karin Lehmann

    … no need to fiddle around.

    The 2.8 user manual installers are online and ready for downloading.


    Please be patient.

    I'm the only one working here on 'GIMP on OS X'. And so I will need some time do do all the stuff here (give support, answer hundreds of mails, build various packages, keep the website up to date, build user manual installers, fix bugs, ….)


  • QuattroGam3r

    QuattroGam3r - 2012-08-30

    Did not mean to belittle any of your efforts lisanet. Your work is very much appreciated. I simply wanted to share an alternative for people asking about help manuals.
    I have since gone back to the Sourceforge files for the app, since the Macports brushes issue made the app unusable for me. However,  after updating to 2.8.2 and using the new help installer,  the app says the help browser is missing from the installation. This is a first run after installing, so came here to see if there was any info. I will look into it and see if there is anything i'm missing or doing wrong.
    Again, thanks for ALL your effort and hard work.

  • Anonymous - 2012-08-31

    I've just d/l and installed 2.8.2 - the native OS X app version, not the X11 version - and I've also d/l and installed the 2.8 Help file package but I have the same problem that GIMP claims the help files aren't installed.

    Should the 2.8 help file installer work with the native app, or only with the X11 version?

1 2 3 > >> (Page 1 of 3)

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks