From: Rob Hranac <robhranac@ya...> - 2002-04-30 17:44:59
> For myself, I tend to copy what Sun's JDK choose.
> So what about renaming "contains" by "accept", as in the
> java.io.FileFilter interface?
A good policy and not a bad idea. I would be interested in others'
opinions as well.
> Class FilterDefault and ExpressionDefault seems to define a set of
> important enums. Would it be better to define an enum type
> and ExpressionType)?
A good idea - am being lazy.
> By the way, is there is a reason why FilterDefault is not named
I generally follow a Reverse Polish naming convention, which we should
probably discuss in the IRC.
> The filter package refer to an OpenGIS specification. Which
> specification is it? Does it defines some interfaces in the
> org.opengis namespace? Could we wrote those interfaces from the
The OGC Filter 0.7.0 specification. I am pretty sure that there are no
interfaces defined and I don't have time to wait for them. I will ask
Peter Vretanos, just to make sure. Your comments are very helpful!
Get latest updates about Open Source Projects, Conferences and News.