Are we looking at the same issue? https://jira.codehaus.org/browse/GEOT-4795 shows a comment in May 2014 (making 12-beta the first chance to try it out).

The versions for each jar we ship are included in the jar filename, or when using maven you can check what versions are being used by typing:

  mvn dependency:tree.

For online reference you can review the root "pom.xml" file which is what we use to configure which jars to use.

https://github.com/geotools/geotools/blob/master/pom.xml


Hunting through this I can find:

      <dependency>
        <groupId>com.vividsolutions</groupId>
        <artifactId>jts</artifactId>
        <version>1.13</version>
        <exclusions>
          <exclusion>
            <groupId>xerces</groupId>
            <artifactId>xercesImpl</artifactId>
          </exclusion>
        </exclusions>
      </dependency>

This also serves an example of how you can control what version of a jar is used in your project.

Hope this helps for next time.

Jody Garnett


On Fri, Aug 1, 2014 at 6:10 PM, Eric Holsinger <eric@heregear.com> wrote:
Good day.

The bug GEOT-4795 still exists as far as I can tell, even though it was posted as fixed in 2011.

I'm sure it's something I've got configured wrong, here's my maven, below. 

FYI:  very confusing with little documentation related to what version of JTS goes with which version of GeoTools for all the versions of GeoTools (like 10, 11, 12).  Can provide time in the saddle to test, document, etc. these issues, let me know.

Thanks in advance.  E.

<version.geotools>12-SNAPSHOT</version.geotools>
<version.geotools.jts>RELEASE</version.geotools.jts> (also tried 1.9, 1.13)

<dependency>
            <groupId>org.geotools</groupId>
            <artifactId>gt-geometry</artifactId>
            <version>${version.geotools}</version>
</dependency>
<dependency>
            <groupId>com.vividsolutions</groupId>
            <artifactId>jts</artifactId>
            <version>${version.geotools.jts}</version>
</dependency>
<dependency>
              <groupId>org.geotools</groupId>
              <artifactId>gt-epsg-extension</artifactId>
              <version>${version.geotools}</version>
</dependency> 

------------------------------------------------------------------------------
Want fast and easy access to all the code in your enterprise? Index and
search up to 200,000 lines of code with a free copy of Black Duck
Code Sight - the same software that powers the world's largest code
search on Ohloh, the Black Duck Open Hub! Try it now.
http://p.sf.net/sfu/bds
_______________________________________________
GeoTools-GT2-Users mailing list
GeoTools-GT2-Users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/geotools-gt2-users