#13 reverseProxy tag don't work

v1.1.1
closed-rejected
nobody
5
2011-09-21
2011-08-03
No

We added a reverseProxy in de gpt.xml for using the correct url but the gpt isn't using in the webapplication.
On the end of the gpt.xml we have added : <parameter key="reverseProxy.baseContextPath" value="http://ontwikkel.mercator.vonet.be/gpt"/> (fig1) but when we click on a link (like shown in attachment fig 2) we get still the internal url (fig3)

Discussion

  • Hoogwys Chris

    Hoogwys Chris - 2011-08-03

    fig1

     
  • Hoogwys Chris

    Hoogwys Chris - 2011-08-03

    fig2

     
  • Hoogwys Chris

    Hoogwys Chris - 2011-08-03

    fig3

     
  • Martin Vaclavik

    Martin Vaclavik - 2011-09-02

    The reverseProxy proxy parameter is working but it must be in <catalog> parent tag. You have it in root <gptConfig> according gpt_proxy.JPG
    The right XPath way is:
    /gptConfig/catalog/parameter@key="reverseProxy.baseContextPath"

    I think this is not bug

     
  • eggwhites

    eggwhites - 2011-09-21

    vaclamar is correct - the reverseProxy parameter must be added as a parameter within the /gptConfig/catalog/ element. If you add the reverseProxy parameter there, test, and still find the issue, we can reopen this bug.

     
  • eggwhites

    eggwhites - 2011-09-21
    • status: open --> closed-rejected
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks