#97 wrong fadetocolor behaviour

GemRB Main Engine
open-accepted
fuzzie
GamePlay (136)
5
2015-07-12
2007-11-24
No

the gamescript action fadetocolor should not freeze the game. However, scipts should not continue when fading.

Here is a patch which solve it. This is maybe an horrible hack, but at least it works.

Discussion

  • Jérôme Gardou

    Jérôme Gardou - 2007-11-24
     
  • Laszlo Toth

    Laszlo Toth - 2007-12-03
    • labels: --> GamePlay
    • milestone: --> GemRB Main Engine
    • status: open --> open-accepted
     
  • Laszlo Toth

    Laszlo Toth - 2007-12-03

    Logged In: YES
    user_id=885460
    Originator: NO

    No, this doesn't seem to be a hack, It seems to be a very elegant solution (to me).
    It is a shame i couldn't come up with this idea (though i use the same in displaystringwait)

    Though this won't stop actions of others, it will stop the cutscene action queue, which seems to be like in the original game. The only additional thing to be done is to mark these actions as blocking.

     
  • Laszlo Toth

    Laszlo Toth - 2007-12-03
    • assigned_to: nobody --> avenger_teambg
    • status: open-accepted --> closed-accepted
     
  • fuzzie

    fuzzie - 2009-06-26

    I am reopening this, because I don't think scripts should block while fading. I can't reproduce that at all in BG2, for me all scripts continue while fading. Does it happen in another game?

    We have made it non-blocking in SVN for now, because otherwise it breaks BG2 cutscenes.

     
  • fuzzie

    fuzzie - 2009-06-26
    • assigned_to: avenger_teambg --> fuzzie
    • status: closed-accepted --> open-accepted
     
  • Jaka Kranjc

    Jaka Kranjc - 2015-07-12

    Oh, we have a bug open for this. Making the two actions blocking still breaks Gaelan's cutscene (when you return with money iirc), but there are counterexamples where this seems to be needed. I forgot a simpler one, but this could also be one of the reasons cut43a isn't working properly (but not the sole one).

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks