#8 `eselect bashrcng-shmfs clean` doesn't intercept errors

closed-accepted
Mauro
shmfs (4)
1
2008-04-22
2008-04-06
No

`eselect bachrcng-shmfs clean` doesn't exits with an error if called `umount` or `rm` fails.

Steps to reproduce (for example):
1. ebuild `equery w lirc` unpack
2. cd /var/tmp/portage/app-misc/lirc-0.8.3_pre1
3. eselect bashrcng-shmfs clean

Results:
fastforward lirc-0.8.3_pre1 # eselect bashrcng-shmfs clean
Wiping /var/tmp/portage

Unmounting memory device(s):
[ tmpfs ] on /var/tmp/portage/app-misc/lirc-0.8.3_pre1 ... umount: /var/tmp/portage/app-misc/lirc-0.8.3_pre1: device occupato
umount: /var/tmp/portage/app-misc/lirc-0.8.3_pre1: device occupato
done.
Restoring memory allocator policy ... done.
rm: impossibile rimuovere la directory `/var/tmp/portage/app-misc/lirc-0.8.3_pre1': Dispositivo o risorsa occupata

now /var/tmp/portage it's spick and span!

Expected results:
fastforward lirc-0.8.3_pre1 # eselect bashrcng-shmfs clean
Wiping /var/tmp/portage

Unmounting memory device(s):
[ tmpfs ] on /var/tmp/portage/app-misc/lirc-0.8.3_pre1 ... failed!

<insert an error message here>

Additional informations:
I'm using these versions:
app-admin/eselect-bashrcng-0.2.0
app-portage/bashrcng-1.1.4
app-portage/bashrcng-core-1.1.1
app-portage/bashrcng-shmfs-1.2.5
virtual/bashrcng-1.1

Discussion

  • Mauro

    Mauro - 2008-04-07
    • priority: 5 --> 1
    • status: open --> closed-invalid
     
  • Mauro

    Mauro - 2008-04-07

    Logged In: YES
    user_id=1229199
    Originator: NO

    sorry, this is not a bashrcng-shmfs bug, it's a bogus.
    bashrcng-shmfs is not a portage python module (it's not a python script), instead it's a bash script and can not interfer with the portage execution itselft.

    this type of error: "/var/tmp/portage/app-misc/lirc-0.8.3_pre1: device occupato"
    happen because the user is inside the "/var/tmp/portage/app-misc/lirc-0.8.3_pre1" dir, which obiovusly it's a user error and not a script bug. Simply move the user outside that dir and re-run the clean script.

    note: if you need to dig into the /var/tmp/portage/* dirs for debugging and/or development, it's better to enable FEATURE "noclean", "keeptemp" and "keepwork" (which are all supported by bashrcng).

     
  • Mauro

    Mauro - 2008-04-07
    • status: closed-invalid --> closed-accepted
     
  • Mauro

    Mauro - 2008-04-07

    Logged In: YES
    user_id=1229199
    Originator: NO

    I'll modify the eselect tool to fix the command output and to prevent bad usage of the tool itself.

     
  • Mauro

    Mauro - 2008-04-07
    • status: closed-accepted --> pending-accepted
     
  • SourceForge Robot

    Logged In: YES
    user_id=1312539
    Originator: NO

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     
  • SourceForge Robot

    • status: pending-accepted --> closed-accepted
     

Log in to post a comment.