#881 Ctrl-C and Ctrl-X do not work with non English layouts

closed-works-for-me
nobody
None
5
2012-11-06
2012-08-16
Qazjap11
No

When pressing Ctrl-C and Ctrl-X with non English layouts (tested with Hebrew and Russian layouts) nothing happens (seletion isn't cut at Ctrl-X nor copied at Ctrl-C). I've noticed that Ctrl-Z and Ctrl-V do work with non English layouts. The copy/cut & paste keyboard shortcut is extremely usefull and it is not comfortable to switch to English layout every time.

Version:
geany 0.21 (built on Mar 19 2012 with GTK 2.24.10, GLib 2.31.20)
Ubuntu 12.04 3.2.0-26-generic x86_64

Related

Bugs: #1056

Discussion

  • Qazjap11

    Qazjap11 - 2012-08-16

    Just tested with geany 1.22 compiled from source. Bug still presents.

    Version:
    geany 1.22 (built on Aug 16 2012 with GTK 2.24.10, GLib 2.32.3)

     
  • Qazjap11

    Qazjap11 - 2012-08-16

    Tested on other system with geany 1.22 compiled from source. The bug does not present here.

    Version:
    geany 1.22 (built on Aug 16 2012 with GTK 2.22.0, GLib 2.26.1)
    Ubuntu 11.04 i686

     
  • Lex Trotman

    Lex Trotman - 2012-08-17

    From your comments it would appear that the problem is a GTK problem, with 2.22 working and 2.24 not.

     
  • Anonymous - 2012-09-12
    • status: open --> closed-duplicate
     
  • Lex Trotman

    Lex Trotman - 2012-09-14

    Not a duplicate, this is Ubuntu, the other bug is Windows.

    Cut copy paste works with Russian keyboard layout for me with Geany 1.23 (git >= c05f1bd GTK 2.24.10, GLib 2.30.2 on Linux mint, will close as works for me if no further input in a few weeks.

    Hebrew is a RTL language not supported properly by Scintilla so the results of cut&paste look strange but it does something.

     
  • Lex Trotman

    Lex Trotman - 2012-09-14
    • status: closed-duplicate --> pending
     
  • Lex Trotman

    Lex Trotman - 2012-11-06
    • status: pending --> closed-works-for-me
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks