#804 Zombie Process <defunct>

closed-fixed
nobody
General (289)
5
2012-11-07
2012-01-05
Anonymous
No

I\'m currently using geany 0.21 on Mint 12 x86. When i start geany it gets a zombie process (or defunct). It happened also with an older version 0.20.
Hope it helps somehow. In the screenshot you can see what i'm talking about in the fourth row from the bottom.

Discussion

  • Lex Trotman

    Lex Trotman - 2012-01-18

    gimp says the png is corrupt.

     
  • Colomban Wendling

    • status: open --> pending-works-for-me
     
  • Colomban Wendling

    I don't see such dead processes here (Debian x64). Can you still reproduce? Does it do that all the time? Have you some weird plugins activated? Any further information?

     
  • Lex Trotman

    Lex Trotman - 2012-11-06

    Happens on Geany 1.23 (git >= eeddd6f), en_AU.UTF-8, GTK 2.24.10, GLib 2.32.3 Linux Mint, Mate DE.

    Appears to be a fork in libvte, not sure what version is being used.

     
  • Lex Trotman

    Lex Trotman - 2012-11-06
    • status: pending-works-for-me --> open-accepted
     
  • Lex Trotman

    Lex Trotman - 2012-11-06

    Using libvte 0.28

     
  • Lex Trotman

    Lex Trotman - 2012-11-07

    @codebrainz, Thanks, appears to be related, the workaround ln -s /usr/lib/libvte9 /usr/lib/vte as suggested in the third link fixes the problem.

    Since we have a workaround and upstream fix, close but with comments still open.

     
  • Lex Trotman

    Lex Trotman - 2012-11-07
    • status: open-accepted --> closed-fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks