#761 Version-Bump from 0.21 to 1.22

closed-invalid
nobody
General (289)
5
2011-10-12
2011-10-10
Alf Gaida
No

With commit d6dfedf4a0f73de193cb19e72fab5a164ab78f4b Version is bumped to 1.22. Is this for real or a failure?

Discussion

  • Anonymous - 2011-10-10

    A lot of people felt that having 0.XX versions made it seem like Geany was still "beta" software instead of the stable and reliable program it actually is. There was a vote on the dev mailing list about how to change the version number and it seems the majority chose to just make the major version 1 and keep the rest of the version the same, as opposed to going to 1.0 or some other arbitrary bump. We are aware it's kind of weird :)

    I'll make the status Pending to give you time to respond in case this is actually going be a problem for you.

    Thanks for the report!

     
  • Anonymous - 2011-10-10
    • status: open --> pending-invalid
     
  • Alf Gaida

    Alf Gaida - 2011-10-12
    • status: pending-invalid --> closed-invalid
     
  • Alf Gaida

    Alf Gaida - 2011-10-12

    I have no problem with this move. The only thing i like to mention: Please change the version of the plugins too. And drop a line in the commits about the version change. I spend a half hour to find this change, as i would pack the latest version directly from trunk for my debian repository. The Problem: Somewhere in the debian packaging packaging is a check of the source version. :)

    Danke für Eure Arbeit und den tollen Editor.

     
  • frlan

    frlan - 2011-10-12

    Geany-Plugins version will updated after 0.21 release. Going to close this ticket.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks