#507 build fails with LINGUAS="en"

v1.25
closed-fixed
General (289)
Unknown
5
2014-08-16
2010-06-12
Chris Mayo
No

geany-0.19 fails to build if you do:

LINGUAS="en" ./configure
make

fails with:

Making all in po
make[2]: Entering directory `/var/tmp/rip/geany-0.19/po'
make[2]: *** No rule to make target `en.gmo', needed by `all-yes'. Stop.

Discussion

  • Enrico Tröger

    Enrico Tröger - 2010-06-12

    This is not a bug.
    "en" is no valid translation for Geany and so it can't be build. LINGUAS can only hold valid, existing translations.

     
  • Enrico Tröger

    Enrico Tröger - 2010-06-12
    • labels: --> General
    • assigned_to: nobody --> eht16
    • status: open --> closed-invalid
     
  • Nobody/Anonymous

    It's still wrong to make the package fail when an invalid language is set in LINGUAS. The build system should just silently ignore the invalid value (like older geany releases already did).
    Please reopen this bug and reconsider this bug for fixing.

     
  • Enrico Tröger

    Enrico Tröger - 2010-06-13
    • status: closed-invalid --> open
     
  • Enrico Tröger

    Enrico Tröger - 2010-06-13

    I still think breaking the build is not strictly wrong, maybe just as not as convenient as it could be.
    I noticed that I actually implemented the requested behaviour already for the Waf build system where it was quite easy.
    If anyone wants to fix this as well for the autotools based build system, patches are welcome. To have a look start at configure.ac:238.

     
  • Vliegende Huiskat

    I can confirm this bug on Slackware 13.1.

    I have set LINGUAS to "nl_NL.utf8" system-wide to make the entire system speak Dutch.
    Unsetting this variable will make geany compile correctly, but it still won't show up in Dutch.

    Seems to be a bug in the makefile in the po folder.

     
  • Vliegende Huiskat

    Btw: geany -V output:
    geany 0.19 (built on Jul 14 2010 with GTK 2.18.9, GLib 2.22.5)

     
  • Colomban Wendling

    Fixed in [768659b89fc8bc6727f5bce7605d417edc859f4a].

    Note however that now LINGUAS has to be specified so it will be in Make's environment, so simply specifying LINGUAS=lang ./configure and then running make like in the initial report won't select "lang" anymore, one has to set it on the make call like LINGUAS=lang make or something to the same end. This however should follow other build system's behavior.

     

    Related

    Commit: [768659]

  • Colomban Wendling

    • status: open --> closed-fixed
    • assigned_to: Enrico Tröger --> Colomban Wendling
    • Found in: --> Unknown
    • Fixed in: --> v1.25
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks