#23 Handle quitting better

closed
None
5
2006-09-06
2006-09-04
stonec
No

I want to start off by saying that I love geany, I use
it full time now. :) There are, however, two big
annoyances for me. The first has already been taken
care of in SVN (opening multiple geany's and that weird
error msg), thanks!

The other involves quitting. In preferences, the
options are to confirm quitting or not. If confirm is
checked, it will ask me if I want to quit regardless of
whether I have made any changes, which I find
irritating. If confirm is unchecked, it will close
geany without a problem even if files have
modifications, thus losing work.

In my opinion, geany should not have this preference at
all and should handle things more intelligently. Like
most text editors, it should prompt you for quitting if
there are modified files, and should not prompt you if
there are no modified files. There's no need to hold
the user's hand provided you prompt them when a file
has been modified so that they can't accidently lose work.

Hopefully you consider making this change. Having to
choose between any annoying confirm message and
potentially losing work is a tough decision. Thanks
again for the great app!

Discussion

  • Nick Treleaven

    Nick Treleaven - 2006-09-04

    Logged In: YES
    user_id=1268692

    Geany should always ask whether to save any files that have
    unsaved changes. Can you give detailed instructions to
    reproduce Geany quitting without confirmation?

     
  • Enrico Tröger

    Enrico Tröger - 2006-09-05

    Logged In: YES
    user_id=1117045

    I just tried it and it works fine here:
    Geany asks you in any case if you want to save your files if
    there are any files with changes. In this case, the option
    to confirm quit is ignored because you already got the
    dialog to confirm quit(whether by saving or ignoring the
    changes).

    The option itself to confirm quit was requested by some
    users and won't be removed. If you don't like it(like me
    ;-)), you can disable it.

     
  • stonec

    stonec - 2006-09-05

    Logged In: YES
    user_id=934948

    I admit that I can't seem to reproduce this bug, and I'm
    starting to question if it really happened or not ;) Feel
    free to close this report, I'll open a new one if I ever get
    it to happen (again?).

    And yes, I can see the logic to the confirm dialog provided
    you never lose data if it's unchecked :)

     
  • Enrico Tröger

    Enrico Tröger - 2006-09-06
    • assigned_to: nobody --> eht16
    • status: open --> closed
     
  • Enrico Tröger

    Enrico Tröger - 2006-09-06

    Logged In: YES
    user_id=1117045

    I closed this bug. If it is really a bug, just re-open
    this one, no need to file a new bug.

     

Log in to post a comment.