#21 --as-needed build failure

closed-fixed
None
5
2006-08-12
2006-08-12
No

It is not possible to build geany when LDFLAGS are set
to -Wl,--as-needed. Attached patch fixes linking order
and solves the problem.

Discussion

  • Enrico Tröger

    Enrico Tröger - 2006-08-12

    Logged In: YES
    user_id=1117045

    Applied your patch and hope it works now on your system. On
    my Debian Sarge it compiled in every case.

     
  • Enrico Tröger

    Enrico Tröger - 2006-08-12
    • status: open --> closed
     
  • Enrico Tröger

    Enrico Tröger - 2006-08-12
    • assigned_to: nobody --> eht16
    • status: closed --> closed-fixed
     

Log in to post a comment.