Always getting EXISTS

  • Kristian

    Kristian - 2014-02-10

    Since a week past, I always seem to be getting EXISTS for every workout I try to upload. Same watch (410); same everything else.

    Has Garmin changed something at their side, which needs to be reflected, mayhap?

    • Thomas Goettlicher

      Same problem here for approx. one week. I use a 910xt and also get EXISTS. I guess Garmin slightly changed the api.

  • Dave Lotton

    Dave Lotton - 2014-02-11

    Hi Kristian,

    Thanks for reporting this. I'll try to take a look this weekend. Would you mind attaching one of the data files you were having a problem with? If I am successful with one of my own files, I'll try uploading yours to see if there's something different about your file.


    Dave L.

    • bertrand bl

      bertrand bl - 2014-02-12

      Hi Dave,
      Same problem with my 910xt. I can upload the files manually with the web interface.
      Please find attached an example of one data file I couldn't upload with your program.


  • Andreas Kurth

    Andreas Kurth - 2014-02-15


    I've been facing the same issue (using a 310XT) for a couple of days. JSON response is:

    {"detailedImportResult":{"uploadId":"","owner":5232953,"fileSize":11,"processingTime":1,"creationDate":"2014-02-15 20:08:44.755 GMT","ipAddress":null,"fileName":null,"report":null,"successes":[],"failures":[{"internalId":null,"externalId":null,"messages":[{"code":415,"content":"The file is of a type we do not support"}]}]}}

    Cheers, Andreas.

  • Ingo Nolden

    Ingo Nolden - 2014-02-15

    HI, me (FR110) having the same problem. Unfortunately I am a new user and didn't have a chance to try this software when it worked. And I have a large bunch of files to upload. Looking for a solution. Thanks

  • Andreas Kurth

    Andreas Kurth - 2014-02-16

    When changing the uploadUri to

    (instead of /json/upload) the upload works for me. does not parse the XML response of course (since it expects JSON), but the file gets transmitted. Weird.

  • Dave Lotton

    Dave Lotton - 2014-02-16

    I've been looking into this issue. Andreas, you are correct. The EXISTS response from gcpuploader is not a correct reflection of the JSON response grom Garmin Connect. The error message in the JSON response is actually a message saying the the file type is not supported, which is obviously not true.

    There's obviously something in my POST transaction that the Garmin Connect API doesn't like now, but used to be okay. I'm working on comparing a POST transaction from the web UI to the POST transaction from gcpuploader to see what is different.

    I wrote gcpuploader over two years ago and I'm not really a programmer, so it is taking me a while to get familiar with it again.

  • Dave Lotton

    Dave Lotton - 2014-02-16

    Okay, I've found the problem.

    For posterity, here's what he problem was:

    In the POST transaction in the multi-part form post I was posting the 'responseContentType' in the first part of the multi-part post before the file name. This worked fine for over two years. Now it doesn't.

    I've swapped the order and it now works.

    I'll try to get the code updated and pushed up today. I'm going to try to clean up some other things as well, such as reporting 'EXISTS' when there's actually a different problem.


    Last edit: Dave Lotton 2014-02-16
  • Dave Lotton

    Dave Lotton - 2014-02-16

    Okay, I've updated everything. If you installed using pip you should be able to update with the following command.

    sudo pip install gcpuploader --upgrade

    pip install gcpuploader --upgrade

    • Kristian

      Kristian - 2014-02-17

      Sorry for not chiming in earlier! But glad to hear it's fixed. Thanks Dave! Really appreciate it. This is a package I use almost daily!

    • bertrand bl

      bertrand bl - 2014-02-19

      Thank you a lot Dave


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks