Problem connecting to server with 2.5.4

Help
grantsa4
2008-12-03
2013-04-29
  • grantsa4

    grantsa4 - 2008-12-03

    When I try and run the Galleon configure, I get a message that says :

    Could not connect to server., Check that the Galleon service is running. Make sure that the ports required by Galleon listed in the FAQ is configured in your PC firewall software.

    The Galleon service is definitely running.
    Any other suggestions?

     
    • x10u8tr

      x10u8tr - 2008-12-04

      You really need to specify your platform - Linux or WinXP or what?

      Have you checked the logs to verify it's listening for connections?
      On my Linux box, I had to disable IPV6.

      Are you using the same address and port when you try to run the GUI?

       
      • Jeremy

        Jeremy - 2008-12-04

        Check out the gui.txt file in the logs directory. Anything interesting in there that might help us troubleshoot the problem?

         
    • grantsa4

      grantsa4 - 2008-12-04

      Sorry, I am using WinXP SP2
      Checked the logs and here is what I see towards the end :

      2008-12-04 07:16:39,875  INFO [AWT-EventQueue-0] Galleon - java.vendor=Sun Microsystems Inc.
      2008-12-04 07:16:39,875  INFO [AWT-EventQueue-0] Galleon - file.separator=\ 2008-12-04 07:16:39,875  INFO [AWT-EventQueue-0] Galleon - java.vendor.url.bug=http://java.sun.com/cgi-bin/bugreport.cgi
      2008-12-04 07:16:39,875  INFO [AWT-EventQueue-0] Galleon - sun.cpu.endian=little
      2008-12-04 07:16:39,875  INFO [AWT-EventQueue-0] Galleon - sun.io.unicode.encoding=UnicodeLittle
      2008-12-04 07:16:39,875  INFO [AWT-EventQueue-0] Galleon - data=C:\Program Files\Galleon\lib\./../data
      2008-12-04 07:16:39,875  INFO [AWT-EventQueue-0] Galleon - sun.desktop=windows
      2008-12-04 07:16:39,875  INFO [AWT-EventQueue-0] Galleon - sun.cpu.isalist=pentium_pro+mmx pentium_pro pentium+mmx pentium i486 i386 i86
      2008-12-04 07:16:39,875  INFO [AWT-EventQueue-0] Galleon - Max Memory: 66650112
      2008-12-04 07:16:39,875  INFO [AWT-EventQueue-0] Galleon - Total Memory: 5177344
      2008-12-04 07:16:39,875  INFO [AWT-EventQueue-0] Galleon - Free Memory: 3770624
      2008-12-04 07:16:40,187 ERROR [AWT-EventQueue-0] Galleon - java.lang.ClassNotFoundException: com.jgoodies.plaf.plastic.PlasticXPLookAndFeel
      2008-12-04 07:16:40,187  INFO [AWT-EventQueue-0] Galleon - Server address: localhost
      2008-12-04 07:19:29,140 ERROR [AWT-EventQueue-0] Galleon - java.rmi.ConnectException: Connection refused to host: localhost; nested exception is:
          java.net.ConnectException: Connection refused: connect: Could connect to server: localhost
      2008-12-04 07:19:29,140 ERROR [AWT-EventQueue-0] Galleon - java.lang.NullPointerException: Could not get apps from server: localhost
      2008-12-04 07:19:36,062 ERROR [AWT-EventQueue-0] Galleon - java.rmi.ConnectException: Connection refused to host: localhost; nested exception is:
          java.net.ConnectException: Connection refused: connect: Could connect to server: localhost
      2008-12-04 07:19:36,062 ERROR [AWT-EventQueue-0] Galleon - java.lang.NullPointerException: Could not retrieve current version from server: localhost

      My log.txt file has this towards the end :

      06:34:11,703 ERROR [WrapperListener_start_runner] Configurator - Invalid server IP address: "my IP address"
      06:34:22,125  INFO [WrapperListener_start_runner] Server - Using port 7288
      06:34:33,140 ERROR [ToGoThread] Tools - javax.crypto.IllegalBlockSizeException: Input length must be multiple of 8 when decrypting with padded cipher
      06:34:34,250  INFO [WrapperListener_start_runner] Server - Using RMI port 1099
      06:34:37,031 ERROR [WrapperListener_start_runner] Server - java.rmi.ServerException: RemoteException occurred in server thread; nested exception is:
          java.rmi.UnmarshalException: error unmarshalling arguments; nested exception is:
          java.lang.ClassNotFoundException: org.lnicholls.galleon.server.ServerControlImpl_Stub (no security manager: RMI class loader disabled)
      06:34:39,000 ERROR [ToGoThread] ToGo - java.net.NoRouteToHostException: No route to host: connect

      Any suggestions?

       
      • Jeremy

        Jeremy - 2008-12-04

        In your configure.xml, what is the value of ipaddress? It looks like it might be "localhost" and that could be giving it problems. I would try setting that to the actual IP address of your machine.

         
        • x10u8tr

          x10u8tr - 2008-12-05

          So what did you try changing your ipaddress to?   If it's set to localhost, make sure you have an entry in your c:\windows\system32\drivers\etc\hosts (or maybe it's lmhosts?) that says localhost is set to 127.0.0.1.  Or you could try using that in your configure.xml file.

           
    • grantsa4

      grantsa4 - 2008-12-04

      Thanks Jeremy. Can I just open to xml file and manually change it?

      <?xml version="1.0" encoding="UTF-8"?>
      <configuration version="2.5.4">
      <server title="Galleon" reload="60" port="7288" httpPort="8081" ipaddress="1.b.c.d" shuffleItems="true" generateThumbnails="false" recordingsPath="" mediaAccessKey="" skin="" debug="false" disableTimeout="false" menu="false"/>
        <tivo address="192.168.16.100" capacity="40" class="org.lnicholls.galleon.server.TiVo" lastChangedDate="Wed Dec 31 18:00:00 CST 1969" name="Tivo Bedroom" numShows="0" path="/index.html" platform="tcd/Series2" port="80" server="DVR-10F4.local." serviceNumber="5400001F01410F4" softwareVersion="9.3.2-01-2-540" id="1"/>
        <musicPlayerConfiguration class="org.lnicholls.galleon.server.MusicPlayerConfiguration" player="classic" randomPlayFolders="true" screensaver="true" showImages="true" skin="" useAmazon="true" useFile="true" id="1"/>
        <dataConfiguration class="org.lnicholls.galleon.server.DataConfiguration" password="" username="" id="1"/>
        <goBackConfiguration autoSubdirectories="false" class="org.lnicholls.galleon.server.GoBackConfiguration" conversionTool="" convertVideo="true" enabled="true" groupByShow="false" publishTiVoRecordings="true" id="1">
          <paths/>
        </goBackConfiguration>
        <screenSaverConfiguration duration="120" />
        <downloadConfiguration CPU="1" bandwidth="1" class="org.lnicholls.galleon.server.DownloadConfiguration" id="1"/>
      </configuration>

      Do I need to manually set the Tivo address to my Tivo's IP address and set the first IP address to my address?

      Do I need to change any of the ports?
      I also have 2 Tivo's on my network? Tivo 1 and Tivo Bedroom. If I want to use Tivo 1, do I need to set the Tivo address to Tivo 1's IP and change the name to "Tivo 1"?

       
      • Jeremy

        Jeremy - 2008-12-04

        Yes, you can edit configure.xml in your favorite text editor, then restart Galleon so it reads your changes.

        You shouldn't have to make any other changes to this file directly. To get your TiVo settings in there, just go to File - ToGo in the Galleon GUI and add your TiVos there.

         
    • grantsa4

      grantsa4 - 2008-12-04

      Thanks Jeremy, I'll give it a try when I get home and hopefully it'll work. Thanks for all the help

       
    • grantsa4

      grantsa4 - 2008-12-05

      Still no luck. Same error

       
      • David L. Crow

        David L. Crow - 2008-12-05

        Have you tried disabling the Windows firewall temporarily to see if that helps?

         
      • Jeremy

        Jeremy - 2008-12-05

        Same errors in the log too? You shouldn't see localhost anymore.

         
      • x10u8tr

        x10u8tr - 2008-12-05

        Okay, so just to make sure, I downloaded the windoze version of 2.5.4 and installed it on my winXP desktop.   ZoneAlarm warned about stuff and I told it to allow.  Galleon Configure came right up.   Clicked on File->Properties and the PC IP Address got set to 192.168.1.97 which is the IP for my desktop.  Don't see a way to set localhost or 127.0.0.1 which is just as well as I really wanted to see if the other TiVo's can see it.   Oh, I also had to reinstall TiVo Desktop 2.6.2 - mostly use galleon on the Linux box and TiVo Desktop on my laptop.

        Hit the test button and it fails to find anything.   Entered the recordings path and media access key.  Both of my TiVo's see both my winxp desktop and the Linux server instances of galleon as well as TiVo Desktop.

        Hmm, when I look at the ToGo menu, only one of the TiVo's is showing up.  Just checked my hosts file and none of the TiVo's are listed there, just the other pc's.  I use static IPs for wired stuff, DHCP for wireless devices like laptop and Wii.

        So looking at my winxp configure.xml, I see that ipaddress="192.168.1.97" and only one of the TiVo's is listed.    Compared to the Linux file, it's got it's own address of 192.168.1.20, and both TiVo's are listed.   Good enough for now.

        Now to shutdown the extra stuff...

         
    • grantsa4

      grantsa4 - 2008-12-05

      Still seeing localhost - not sure why though.

      In my Wrapper.conf file I noticed :

      # Java Additional Parameters
      #wrapper.java.additional.1=-Droot=C:\Documents and Settings\jtk\My Documents\Eclipse-local\galleon

      That folder does not exist. Could this be a problem?

       
    • grantsa4

      grantsa4 - 2008-12-05

      So, I went into configure.xml and changed the IP address to "Test" and restarted the server and then tried to connect and Log said could not find "Test", which I expcted.

      Then I tried changing the IP to 127.0.0.1 and restarting it and then got couldn't find localhost.

      Then I tried changing it to my laptop's IP address and restarted and it still sees it as localhost.

      Any ideas form anyone?

       
    • Jeremy

      Jeremy - 2008-12-05

      That Eclipse line in wrapper.conf doesn't matter because it is commented out.

      I could be wrong about the localhost part ...

       

Log in to post a comment.