Compiling Under Cygwin

Patrick
2007-02-09
2013-04-03
  • Patrick

    Patrick - 2007-02-09

    Hi,

    I'd like to compile this plugin to use in gaim under windows, but I'm having some trouble. I'm using gaim2.0.0beta6. Here's what I've tried so far:

    - downloaded the zipped DLL and copied to C:\[...]\Application Data\.gaim\plugins\ This seemed to be the easiest option, but it didn't work. I also tried copying the DLL to the plugins dir in gaim's install folder: no dice. I have the plugin up and running on my Fedora box at work, so I know where to look for it (under gaim 2's plugins screen) but it doesn't show up there on my windows machine.

    - set up the environment builder and attempted to build the DLL as per the instructions in the tarball
    The environment builder seemed to work perfectly under cygwin. I copied the unpacked gaim-extprefs0.5 directory to {gaim}/plugins and make failed, complaining about not being able to find global.mak at the specified location. I tried tinkering with Makefile.mingw to no avail, even when I resolved the path issues, the compiler spat out a bunch of errors that I was unable to decipher.

    Anyways, if anyone has experience in this, I would appreciate any pointers.

    Thanks,
    Patrick

     
    • Anonymous - 2007-02-25

      Can you post the output with the errors from the Debug Window when starting gaim? Or run gaim in debug mode (gaim -d) from the command window to see what the error msg is when gaim is trying to load dll ?

      Other people have been having problems with compiling/using Extended Prefs with Windows.

      If you want to file a bug with that error output in the comments, then I can have a look at it.

       
    • Patrick

      Patrick - 2007-02-25

      I think this is the relevant line of output:

      plugins: probing C:\Documents and Settings\Patrick\Application Data\.gaim\plugins\extprefs.dll
      plugins: C:\Documents and Settings\Patrick\Application Data\.gaim\plugins\extprefs.dll is not loadable: The specified module could not be found.

       
    • Anonymous - 2007-02-26

      Just checking, but I guess you followed the directions at:

        http://gaim.sourceforge.net/win32/build.php  ?

      Can you file this as a bug and report what gaim, extended prefs, and GTK versions you're using so we can keep track of this.

       
    • Patrick

      Patrick - 2007-02-26

      Hi again,

      I did follow those instructions in the first place, but like I said in the original post, I couldn't get the DLL to build from the Makefile. So the output from "gaim -d" that I just posted came from downloading the pre-built DLL and putting it in the appropriate folder.

      I'm using:

      - gaim2.00beta6
      - gtk ... Not sure which version exactly, but it's quite recent
      - for the time being, I'm using the most current version of the pre-built windows DLL for extprefs

       
    • Anonymous - 2007-03-04

      I was fooling around with compiling gaim and gaim-extprefs under cygwin and there is a problem with the Makefile.mingw in the extprefs src directory (as you've pointed out). The string "$(GAIM_TOP)/src" in the extprefs Makefile.mingw file  should be replaced by "$(GAIM_TOP)/libgaim" in all instances. There are also some other errors in the Makefile when referencing gaim code.

      I'll have a look at it later this week for committing to the cvs.

      Even after fixing this issue, another issue pops up when it can't find some libraries when compiling extprefs.dll which I will also look at.

       
    • Anonymous - 2007-03-10

      I've fixed the problem with compiling Extended Prefs under cygwin.
      You can update the source from cvs or Browse the CVS Repository and download the src/Makefile.mingw and replace that with the older one in your local extended-prefs/src directory.

      Also, the directory where extprefs should be extracted is the gaim/gtk/plugins directory

      Running make -f Makefile.mingw from the extended prefs directory should now compile the plugin for Windows.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks