Problem with GAG

Help
joany
2006-12-07
2013-05-28
  • joany

    joany - 2006-12-07

    I recently installed Linux on my computer's second hard drive.  My goal is to use the GAG Boot Manager to boot Linux from a bootable floppy disk instead of booting with GRUB on the master boot record, so I used the option of installing GRUB in the Linux root directory instead of in the MBR.  This particular distro (MEPIS) doesn’t seem to offer the option to create a Linux boot floppy during installation.

    My problem is with GAG.  When I start the computer from the floppy disk, the word "GAG" briefly appears in the upper left corner of the screen after the BIOS checks are complete.  Then a green "error reading disk" message appears and the computer hangs.
    I copied GAG from an image file onto 3 separate floppy disks with the same result with each disk.  I also tried using an earlier version of GAG.  Am I correct to assume the "error reading disk" message means that GAG is having trouble reading my hard drives, and not that there is an error in reading the floppy? 

    Here are some particulars about my system:

    Both of my hard drives are connected to the same IDE controller, with HD0 jumpered as “master” and HD1 jumpered as “slave.” 
    HD0 is 30GB in size and has a primary FAT32 partition where Windows98 lived once upon a time.  Windows98 is now gone, so the primary partition is now just a tiny “legacy” boot partition that is used to start Windows 2000 Pro, which lives on a second logical FAT32 partition.

    HD1 is 120GB in size and has six partitions: a primary NTFS partition I use for all my data, a logical FAT32 partition I use to store backup image files of HD0, a logical NTFS partition I have dedicated to a Windows 2000 page file.  Following these partitions are the Linux partitions for /root/ and /home/, plus a Linux swap partition.
    I also have a CD/DVD-ROM plus a CD/DVD RW drive connected to a second IDE controller.  These are jumpered as “cable select.”

    The motherboard is quite ancient (circa 1999) but the BIOS doesn’t seem to have any problem recognizing all of the drives and all of the partitions on the hard drives.  The OEM doesn’t offer any recent BIOS upgrades, although I had reflashed the BIOS with the latest one that was offered (circa 2002).  My processor is an AMD K-6.

    I apologize for the length of my post, but I wanted to include as much information as possible to help the experts trouble shoot the problem.  Has anyone had the “error reading disk” message when using the GAG Boot Manager and did you find a work-around?  Do any experts out there have ideas why my particular configuration might be causing this error? Is GAG incompatible with my processor?  Could the problem be with having both hard drives on the same IDE controller, or the existence of NTFS partitions on HD1, or the number of GB on the second hard drive?  Should I try unplugging HD1 to see if GAG recognizes HD0 alone?

    Thanks in advance for any help you can provide.

     
    • NZ-Wanderer

      NZ-Wanderer - 2006-12-18

      Can't help you with your problem, but I can say it shouldn't be your hard drive setup...
      I have a 320gb IDE as primary Master with 2 partitions (ntfs, Ext3)
      I have a 200gb IDE as Primary Slave with 3 partitions (ntfs)
      I have a 160gb IDE as Secondary master with 6 partitions (ntfs, fat32)
      I have a 320gb SATA with 10 partitions (ntfs, Ext3, fat32)

      I am presently using GAG to dual boot between Vista on the SATA's first partition and Kubuntu (Linux) on the SATA's Second partition.
      I did have XP on ther secondary slave, but decided to wipe it cause I didn't really need it for now)

      So you see, it doesn't matter what sort of configuration you have on your HDD, GAG should still work.

      Sorry for not being able to help a lot...

       
    • joany

      joany - 2006-12-21

      NZ Wanderer -

      I agree that it's unlikely that the error is due to the number of drives, etc., since your hard disk configuration is certainly more complicated than mine. I'm thinking maybe there's an error in the partition table on the second hard disk.  Partition Magic keeps coming up with an "error" on that disk, although PM can read the disk.  Do you know of any reliable tools that can detect and fix errors in the partition table??

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks