win2000 won't boot after reinstall

Help
SocialFish
2004-02-22
2013-05-28
  • SocialFish

    SocialFish - 2004-02-22

    I didnt want to hijack the other thread, and it sounds like our situations are different.

    I had several Windows partitions as well as several Linux partitions on my 80Gig HD.  I installed GAG and I was very impressed.  It is simple and effective.  I especially like the way it can reside completly on a floppy...next time I might only do that because...

    After installing another version of Linux, I went back into GAG and entered the new info in the setup screen.  When I rebooted and tried to load Windows, the message 'NTLDR couldn't be found' was presented to me on a black screen with a few randomly placed mulit-colored characters.

    Rebooting gave the same result.  I began to worry, but then decided to just restore the boot and mbr using win2000's repair console.  Both programs reported back that they worked, but when I rebooted again, I got the same strange screen.

    I'm about 5 days into the process of understanding what the boot sector is and what it's supposed to look like, and I'm hopeful that I can restore the bootability of this partition that held win2000pro.  It's the first physical partition and was an NTFS filesystem.  I'm working with several guru's in this area of sector editing and hope to have good news to share soon.

    until then, I'd be careful installing this on a HD and then making major changes to it.

    -Mike

     
    • SocialFish

      SocialFish - 2004-03-18

      I am a little discouraged that no one has responded to my note.  I wish I had more positive information to share, but the bootability of my win2000 installation was never achieved.  I was forced to reinstall the whole OS and re-partitioned my drive. 

      I was looking around in here and found a note under the other forum requesting that an image of the boot sector could be made before any changes are made, and boy do I wish that were an option before I wiped out my system.

      -Mike

       
      • Future Dood

        Future Dood - 2004-03-18

        Wow.  So sorry to hear that.  I haven't checked back here until today (got a notice you'd left a message)...

        I had the same thing happen, as I may have mentioned in another post.  The solution was to edit the boot.ini and change the target boot partition (increment or decrement the partition #)...  I never tracked down why this happens, but somehow, either the partition info is changed, and boot.ini is then wrong, or, perhaps during the boot phase, the boot.ini info is erroneously changed.  If someone could clarify, that would be great.

        Maybe this will help someone else.

         
        • SocialFish

          SocialFish - 2004-03-23

          futuredood...you ROCK!!  I had been crippled for several weeks, but now that I re-checked my boot.ini, all is working as it's supposed to.  Now I get to try using GAG again (yes... I am very brave.)
          -Mike

          P.S.  Maybe this time I'll make a backup of my MBR first. ;-)

           
    • Future Dood

      Future Dood - 2004-03-18

      erp, sorry to keep x-posting...

      Tool to save MBR...

      I found one, btw. It's called MBRutil.exe -- free from Powerquest (Symantec?). You can do the same thing with any good Diskeditor, or via a Linux partition or LiveCD using DD.

       
    • Mark Craig

      Mark Craig - 2004-04-10

      Mike:

      It never had anything at all to do with the MBR, as Future Dood implied.  I'd suggest you buy a good reference book about Windows 2000, take some MSCE courses, or spend some time browsing the MS Knowledgebase.  Your predicament only happened because you didn't understand certain fundamentals of the OS you were using.

      You should have known better than to f**k with any boot manager - much less an open-source one with almost nonexistent support - until you understood EXACTLY the process by which each OS boots.

       
      • SocialFish

        SocialFish - 2004-04-11

        Mark, I'm sure your trying to be helpful and that you meant well, but your response lacks something that many people in a forum such as this seem to think is important.  Some of those things might include the title of a good reference book that you found helpful, a tip about what you might think to be the cause, sharing a similar experience, or even a bit of support. 

        Thanks for trying, buit I'll hold out for a more useful reply.

         
    • Anonymous - 2004-05-14

      Please disregard Mark Craig's post. You don't need an MCSE to solve this one.
      These are the fundementals:
      MBR Bootloader->NTLDR->Windows.exe/WinNT.exe

      This should work

      1. Boot via the installation CD.
      2. Go into the recovery console.
      3. Type fixboot [drive] (ex. fixboot C:)  and press enter.
              This overwrites your boot sector.
      4. Type exit and press enter.
      5. Post back if this has not solved your problem.

      The MBR bootloader loads an OS specific loader.

      NTLDR (New Technologies Loader) is the OS specific loader, it executes WinNT.exe or Windows.exe.

      WinNT.exe or Windows.exe is the kernel of the windows operating system which gives you that pretty, blue screen (of death).

       
      • SocialFish

        SocialFish - 2004-05-14

        Thanks for the reply saroth.  I didn't make myself very clear in the first post.  The two programs I tried were fixboot and fixmbr.  Neither helped resolve the situation.  It's hard to accept, but I think what really happened was that boot.ini somehow got edited as futuredood suggested.  I've since blamed the Linux bootloader for this, but cannot be certain.  I've since re-installed the OSs and am hesitant to "f**k with any boot manager" as macraig so eloquently suggested. :)
        -Mike

         
    • MultiBoot

      MultiBoot - 2005-11-21

      see thread "Tip: Avoiding Unbootable Partitions" this applies to your situation (and others)

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks