GAG sees 2nd disk (ubuntu) but no boot error

  • rgherriott

    rgherriott - 2009-04-16

    Hi- hope someone can help. I have been using GAG for a while with success. I just installed another HD in my system with Ubuntu. The disk boots fine when it is the only HD in the system and configured as a master. When I configure it as a slave and reconnect my main disk (set as master) GAG 'sees' the disk and the swap partition but when I try to add Ubuntu OS I get an error message to the effect that there is no boot
    record. I have tried all the combinations available in GAG without success. Any thoughts?

  • Greg White

    Greg White - 2010-08-29

    I have a similar problem.  I have Windows XP on a PATA drive and Ubuntu 10.04 on a SATA drive.  I have the PATA drive set as Master boot drive.  I'm able to boot into Windows XP with no problems.  I'm able to add Ubuntu to GAG menu but unable to run it because GAG complains that Grub is not on the root SuperBlock.  I have installed Grub2 on the MBR of the SATA drive and it boots by itself with no problems if I disconnect the PATA drive and set the SATA drive with Ubuntu as only HDD.  I've tried GAG because Grub2 does not like booting the SATA drive when it is set as secondary drive.  Do I need to down grade to Grub Legancy in order to get GAG to work?

  • Alex Soyouth

    Alex Soyouth - 2011-01-16


    From my own experience, downgrading to GRUb legacy allowed me to boot Ubuntu from GAG, but I am stuck with another problem I just posted on this forum, which is that my GAG gets destoryed every second boot…


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks