Virtual printer missing

Anonymous
2011-03-08
2014-11-03
  • Anonymous - 2011-03-08

    I am using Ubuntu 10.10 and I have gnome-manual-duplex v0.34 installed. However, I can't find the virtual printer as shown on your screenshots. Have this feature being removed?

     
  • Rick Richardson

    Rick Richardson - 2011-03-08

    No.

        2)  Add to Panel -> Gnome Manual Duplex applet -> Add
                …Do it at least once, then…
            Print -> GnomeManualDuplex (Virtual Printer) -> Print

     
  • Rick Richardson

    Rick Richardson - 2011-03-08

     
  • Anonymous - 2012-10-14

    I can't find the GnomeManualDuplex (Virtual Printer),either.  my os is opensuse11.4 and I have gnome-manual-duplex 0.46 installled. i have tried the operations in #2,but not working. my printer is HP Laserjet 1022 connected to a server in  local lan network. is GnomeManualDuplex (Virtual Printer) only functional for local printers?

     
  • Rick Richardson

    Rick Richardson - 2012-10-14

    No. GnomeManualDuplex is functional for all printers.

     
  • Christopher Vella

    I installed the package in Arch Linux with Gnome 3.14. There's no virtual printer but don't have a clue how to "add the app to the panel" in gnome 3.

     
  • Rick Richardson

    Rick Richardson - 2014-10-31

    From https://sourceforge.net/projects/g-manual-duplex/files/?source=navbar :

    Using the Gnome 3 Shell GUI:
        1)      $ gnome-session-properties
                Startup Programs -> GnomeManualDuplex -> Enable
                [logout][login]
        2)      Print -> GnomeManualDuplex (Virtual Printer) -> Print
    
     
    Last edit: Rick Richardson 2014-10-31
  • Christopher Vella

    There is no gnome-session-properties in Gnome 3.14 on Arch. Is there a manual way of loading it?

     
  • Rick Richardson

    Rick Richardson - 2014-11-02

    From https://sourceforge.net/projects/g-manual-duplex/files/?source=navbar :

    Using the Gnome 3 Shell GUI:
        1)      $ gnome-session-properties 
                Startup Programs -> GnomeManualDuplex -> Enable
                [logout][login]
        2)      Print -> GnomeManualDuplex (Virtual Printer) -> Print
    
        If gnome-session-properties does not exist (Gnome 3.12+), you can
        manually install it with:
    
        $ sed -e "s/\(.*Autostart.*\)=.*/\1=true/" \
            < /etc/xdg/autostart/gmd-applet-3.py.desktop \
            > ~/.config/autostart/gmd-applet-3.py.desktop
    
     
  • Christopher Vella

    I did that. The .desktop file was added to the ~/.config/autostart folder. I made it executable. Logged out and in again. Nothing changed. No icon appeared. Applet doesn't seem to be running. I even tried launching the .desktop file manually. No change.

    Then I tried running the /usr/share/gnome-manual-duplex/gmd-applet-3.py file in a terminal and I got

      File "./gmd-applet-3.py", line 41
        fp = open("/var/tmp/gmd/error.log", "a")
                                               ^
    TabError: inconsistent use of tabs and spaces in indentation
    
     
    Last edit: Christopher Vella 2014-11-03
  • Rick Richardson

    Rick Richardson - 2014-11-03

    What does this say:

    $ /usr/share/gnome-manual-duplex/gmd-applet-3.py run-in-tray
    path: 3 event: <flags G_IO_IN="" of="" type="" GIOCondition="">
    path: 3 event: <flags G_IO_IN="" of="" type="" GIOCondition="">
    path: /var/tmp/gmd/rick/list event: 8
    path: /var/tmp/gmd/rick/list event: 9
    path: 3 event: <flags G_IO_IN="" of="" type="" GIOCondition="">
    path: /var/tmp/gmd/rick/list/ event: 2
    path: 3 event: <flags G_IO_IN="" of="" type="" GIOCondition="">
    path: /var/tmp/gmd/rick/list event: 5
    ^Z

    Works fine here. Icon is put in the tray.

     
  • Christopher Vella

    I think the issue is the default python version. When I run the python script as requested I get the indentation issue above when I prepend python2 it works fine. I will therefore modify the .desktop file accordingly.

     

Log in to post a comment.