Thanks. Your response helped lead me to the solution.

I tried installing the packages, one-by-one, that you listed which weren't listed by my server when I ran the same command (after installing apt-show-versions). That didn't work. So, I watched the output of the installation process, and captured some of the error messages. I saw "pcap" mentioned, so I searched the Hardy list of packages, and installed libnet-pcap-perl, which also installed libpcap. That worked. I reverted the server to its previous state and tried again, and confirmed that:

sudo aptitude install libnet-pcap-perl

was all that I needed before running the fwknop installation.

Just before I sent this email I saw that Michael Rash has a newly built RPM, so I'll have to revert the server again and try that, too, and report on my results (tonight).

- Scott

----- Original Message ----
From: Marius Rugan <>
Sent: Thursday, June 12, 2008 7:36:42 AM
Subject: Re: [Fwknop-discuss] Install on Ubuntu Server


i got a debian etch
here is my apt-show-versions

apt-show-versions | grep perl

libconfig-inifiles-perl/etch uptodate 2.39-2
libplrpc-perl/etch uptodate 0.2017-1.1
libtext-iconv-perl/etch uptodate 1.4-3
perl-modules/etch uptodate 5.8.8-7etch3
libnet-daemon-perl/etch uptodate 0.38-1.1
libapt-pkg-perl/etch uptodate 0.1.20
libdbd-mysql-perl/etch uptodate 3.0008-1
perl/etch uptodate 5.8.8-7etch3
liblocale-gettext-perl/etch uptodate 1.05-1
libdbi-perl/etch uptodate 1.53-1etch1
libtext-charwidth-perl/etch uptodate 0.04-4
perl-base/etch uptodate 5.8.8-7etch3
libtext-wrapi18n-perl/etch uptodate 0.06-5

fwknop 1.9.5 installs without a problem under this config

core modules fwknop is using come with the package and the install script handles them

[+] Installing IPTables::ChainMgr 0.7 perl module in /usr/lib/fwknop/
Checking if your kit is complete...
Looks good
Writing Makefile for IPTables::ChainMgr
cp lib/IPTables/ blib/lib/IPTables/
Manifying blib/man3/IPTables::ChainMgr.3pm
Installing /usr/lib/fwknop/IPTables/
Installing /usr/lib/fwknop/man/man3/IPTables::ChainMgr.3pm

On Thu, Jun 12, 2008 at 1:51 PM, <> wrote:
I am attempting to install the latest fwknop on the latest upgraded Ubuntu Server (2.6.24-18-server). I have build-essentials installed, but I don't know if fwknop requires that. Perhaps there are other libraries or Perl modules that I need to install first. During the attempted fwknop installation I get messages such as:


Warning: prerequisite Test::Manifest 1.14 not found.


Can't locate Net/ in @INC (@INC contains: /usr/lib/fwknop/i486-linux-gnu-thread-multi /usr/lib/fwknop /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at fwknopd line 47.
BEGIN failed--compilation aborted at fwknopd line 47.
[*] fwknopd does not compile with "perl -c".  Download the latest sources from:


What are the prerequisites for fwknop installation on Ubuntu Server?


Check out the new Marketplace.
It's the best place to buy or sell services for
just about anything Open Source.
Fwknop-discuss mailing list