#235 intrapositioned negation deprecated

open-invalid
None
5
2012-08-29
2012-08-29
Anonymous
No

Using:
fbw 5.1.0.3599 on debian squeeze with iptables 1.4.8-3

Since upgrading to squeeze i get this deprecated warnings when running fwb script. I'ts thrown on rules with negated destination address scoopes.

---
Rule 12 (global)
Rule 13 (global)
Using intrapositioned negation (`--option ! this`) is deprecated in favor of extrapositioned (`! --option this`).
Using intrapositioned negation (`--option ! this`) is deprecated in favor of extrapositioned (`! --option this`).
Using intrapositioned negation (`--option ! this`) is deprecated in favor of extrapositioned (`! --option this`).
Rule 14 (global)
Using intrapositioned negation (`--option ! this`) is deprecated in favor of extrapositioned (`! --option this`).
Using intrapositioned negation (`--option ! this`) is deprecated in favor of extrapositioned (`! --option this`).
Using intrapositioned negation (`--option ! this`) is deprecated in favor of extrapositioned (`! --option this`).
Rule 15 (global)
Rule 16 (global)
---

It doesen't affect function. I'ts just an information.

Best regards

Per-Ola

Discussion

  • Vadim Kurland

    Vadim Kurland - 2012-08-29

    you need to set "version" right in the firewall object to reflect actual version of iptables running on your machine, this will make fwbuilder generate iptables commands using extrapositioned negation

     
  • Vadim Kurland

    Vadim Kurland - 2012-08-29
    • status: open --> open-invalid
     
  • Vadim Kurland

    Vadim Kurland - 2012-08-29
    • assigned_to: nobody --> vkurland
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks