Thanks to Gentoo's portage system, I've already tried compiling/installing fuse and sshfs from source when I tried upgrading to sshfs 1.6 and fuse 2.6.0_pre2.

On 4/13/06, Miklos Szeredi <> wrote:
> Running with '-s' doesn't make a difference.
> When I run gdb I get (output is scrubbed a bit)
> -------------------------------------------------------
> > gdb sshfs
> (gdb) run -d user@host:~/projectdir/ /localdir/
> Starting program: /usr/bin/sshfs -d user@host:~/projectdir/ /localdir/
> (no debugging symbols found)
> (no debugging symbols found)
> [Thread debugging using libthread_db enabled]
> [New Thread -1210927424 (LWP 14186)]
> Couldn't get registers: No such process.
> (gdb)


It would be best, if you could compile/install fuse and sshfs from
source and try again.

> I've also noticed that even when sshfs is successful there aren't any
> threads that I can find and terminate. There used to be ... that was
> probably before I added the fuse module support in the kernel. Could that
> have something to do with the problem?