Running with '-s' doesn't make a difference.

When I run gdb I get (output is scrubbed a bit)
> gdb sshfs
(gdb) run -d user@host:~/projectdir/ /localdir/
Starting program: /usr/bin/sshfs -d user@host:~/projectdir/ /localdir/
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1210927424 (LWP 14186)]
Couldn't get registers: No such process.

When I run the same sshfs command from the command line, with the '-f' option, I get
> sshfs user@host:~/projectdir/ /localdir/ -f
Segmentation fault

Using the '-f' option in the gdb command makes no difference.

I've also noticed that even when sshfs is successful there aren't any threads that I can find and terminate. There used to be ... that was probably before I added the fuse module support in the kernel. Could that have something to do with the problem?


Can you try with '-s' also?

A backtrace from the segfault would be useful.  Try starting sshfs
from gdb:

> gdb sshfs
(gdb) run -d user@host:/projectdir /localdir
Program received signal SIGSEGV, Segmentation fault.
(gdb) bt