codepage/umlaut problems

2009-11-18
2013-04-24
1 2 > >> (Page 1 of 2)
  • Walter Bender

    Walter Bender - 2009-11-18

    Hi There,

    thanks for the great work ! fuse-ext2 works very well for me besides the fact that it has problems accessing germanic umlauts. I don't know how to change the codepage using fuse-ext2 0.0.6 and Mac OS X 10.6.2. 

    Thanks,
    h2o

     
  • Anonymous - 2010-01-18

    I'm also having the problems with the german umlauts on fuse-ext2 0.0.7 on OS X 10.5.8… Any solutions right there?

    thanks
    benny

     
  • Anonymous - 2010-01-18

    Ok, just recognized, that there are also problems with accented glyphs like é and ù. The Codepage seems either not beeing unicode compatible or there is a problem with the conversion from unicode to mac roman in finder or terminal.

     
  • Anonymous - 2010-01-18

    Since this is also affecting the read-only mode I would say it's a serious bug, because I imagine this problem exists for all languages with non ASCII/Mac Roman Characters and lets tons of files stay unreadable

     
  • Alper Akcan

    Alper Akcan - 2010-01-18

    hi,

    if you have a linux machine, can you create me a file system that contains different chars, like you have. so i can debug and fix the problem. i will be very happy if you help me with this, here is the steps to create a fake fs with desired file names.

    # mkdir tmp
    tmp # cd tmp
    tmp # mkdir mnt
    tmp # dd if=/dev/zero of=./test.ext2 bs=1024 count=1024
    1024+0 records in
    1024+0 records out
    1048576 bytes (1.0 MB) copied, 0.00362451 s, 289 MB/s
    tmp # mkfs.ext2 ./test.ext2 
    mke2fs 1.41.8 (11-July-2009)
    ./test.ext2 is not a block special device.
    Proceed anyway? (y,n) y
    .
    .
    .
    # 
    tmp # mount ./test.ext2 ./mnt/ -o loop
    tmp # cd mnt
    tmp/mnt # ls
    lost+found
    tmp/mnt # touch file.00
    tmp/mnt # touch file.01
    tmp/mnt # touch file.02
    tmp/mnt # touch file.03
    tmp/mnt # cd ../
    tmp # umount mnt
    tmp # bzip2 test.ext2
    

    you can use touch to create different files with any chars… then it would be great if you send me the test.ext2.bz2 file via email. 'alper.akcan at gmail dot com'

    thanks,
    alper.

     
  • Anonymous - 2010-01-19

    i sent you the file  to the given address

     
  • Alper Akcan

    Alper Akcan - 2010-01-19

    hi,

    i think that this is not related to the mount or filesystem support. i can not even see the chars correctly on my linux pc - slackware - :| i think console emulator should be set to correct charset, i do not know how, maybe the LANG variable can help.

    i do not see any charset related options in mount for ext2/3/4. i am open to suggestions :)

    alper.

     
  • Anonymous - 2010-01-19

    I just tried to mount the created file system again under ubuntu 9.10 karmic and it still works. -> see pictures
    Changing the system language to English didn't have any effect an kept the chars right.




    benny

     
  • Alper Akcan

    Alper Akcan - 2010-01-20

    hi,

    what is the output for locale command

    # locale
    LANG=en_US
    LC_CTYPE="en_US"
    LC_NUMERIC="en_US"
    LC_TIME="en_US"
    LC_COLLATE=C
    LC_MONETARY="en_US"
    LC_MESSAGES="en_US"
    LC_PAPER="en_US"
    LC_NAME="en_US"
    LC_ADDRESS="en_US"
    LC_TELEPHONE="en_US"
    LC_MEASUREMENT="en_US"
    LC_IDENTIFICATION="en_US"
    LC_ALL=
    

    alper.

     
  • Anonymous - 2010-01-24

    With the standard settings I get this

    #locale
    LANG=de_DE.UTF-8
    LC_CTYPE="de_DE.UTF-8"
    LC_NUMERIC="de_DE.UTF-8"
    LC_TIME="de_DE.UTF-8"
    LC_COLLATE="de_DE.UTF-8"
    LC_MONETARY="de_DE.UTF-8"
    LC_MESSAGES="de_DE.UTF-8"
    LC_PAPER="de_DE.UTF-8"
    LC_NAME="de_DE.UTF-8"
    LC_ADDRESS="de_DE.UTF-8"
    LC_TELEPHONE="de_DE.UTF-8"
    LC_MEASUREMENT="de_DE.UTF-8"
    LC_IDENTIFICATION="de_DE.UTF-8"
    LC_ALL=

    After changing the language in "system preferences - language support" to English (US) i get this

    locale
    LANG=en_US.UTF-8
    LANGUAGE=en_US.UTF-8
    LC_CTYPE="en_US.UTF-8"
    LC_NUMERIC="en_US.UTF-8"
    LC_TIME="en_US.UTF-8"
    LC_COLLATE="en_US.UTF-8"
    LC_MONETARY="en_US.UTF-8"
    LC_MESSAGES="en_US.UTF-8"
    LC_PAPER="en_US.UTF-8"
    LC_NAME="en_US.UTF-8"
    LC_ADDRESS="en_US.UTF-8"
    LC_TELEPHONE="en_US.UTF-8"
    LC_MEASUREMENT="en_US.UTF-8"
    LC_IDENTIFICATION="en_US.UTF-8"
    LC_ALL=

    I think your language settings should also have this unicode-extension to support the other languages properly. But I don't know how to set this on slackware

    benny

     
  • Anonymous - 2010-01-31

    solution on the way?

     
  • Alper Akcan

    Alper Akcan - 2010-01-31

    hi, i was on vocation for past six days, and without network connection. i will check this week. alper.

     
  • Rüdiger Schulz

    Rüdiger Schulz - 2010-02-05

    I can confirm and detail this bug on Snow Leopard with a USB connected IDE drive formatted with ext3. I can access folders with Umlauts, but I cannot copy them in Finder. I copied a large MP3 collection, and all directories with Umlauts were not copied, without any error.

    The debug output during such an operation:

    LOOKUP /mp3/Bands/Björk
    fuse-ext2: enter [op_getattr (../../fuse-ext2/op_getattr.c:30)]
    fuse-ext2: path = /mp3/Bands/Björk [op_getattr (../../fuse-ext2/op_getattr.c:31)]
    fuse-ext2: ext2fs_namei(e2fs, EXT2_ROOT_INO, EXT2_ROOT_INO, /mp3/Bands/Björk, ino); failed [do_readvnode (../../fuse-ext2/do_readinode.c:44)]
    fuse-ext2: do_readvnode(/mp3/Bands/Björk, &ino, &vnode); failed [op_getattr (../../fuse-ext2/op_getattr.c:41)]
       unique: 3, error: -2 (No such file or directory), outsize: 16
    unique: 1, opcode: LOOKUP (1), nodeid: 16565, insize: 48
    LOOKUP /mp3/Bands/Björk
    fuse-ext2: enter [op_getattr (../../fuse-ext2/op_getattr.c:30)]
    fuse-ext2: path = /mp3/Bands/Björk [op_getattr (../../fuse-ext2/op_getattr.c:31)]
    fuse-ext2: ext2fs_namei(e2fs, EXT2_ROOT_INO, EXT2_ROOT_INO, /mp3/Bands/Björk, ino); failed [do_readvnode (../../fuse-ext2/do_readinode.c:44)]
    fuse-ext2: do_readvnode(/mp3/Bands/Björk, &ino, &vnode); failed [op_getattr (../../fuse-ext2/op_getattr.c:41)]
       unique: 1, error: -2 (No such file or directory), outsize: 16
    unique: 2, opcode: LOOKUP (1), nodeid: 16565, insize: 48
    LOOKUP /mp3/Bands/Björk
    fuse-ext2: enter [op_getattr (../../fuse-ext2/op_getattr.c:30)]
    fuse-ext2: path = /mp3/Bands/Björk [op_getattr (../../fuse-ext2/op_getattr.c:31)]
    fuse-ext2: ext2fs_namei(e2fs, EXT2_ROOT_INO, EXT2_ROOT_INO, /mp3/Bands/Björk, ino); failed [do_readvnode (../../fuse-ext2/do_readinode.c:44)]
    fuse-ext2: do_readvnode(/mp3/Bands/Björk, &ino, &vnode); failed [op_getattr (../../fuse-ext2/op_getattr.c:41)]
       unique: 2, error: -2 (No such file or directory), outsize: 16
    

    The funny thing is, if I copy the same directory on a shell with the cp command, it works like a charme.

     
  • Anonymous - 2010-02-27

    Last message was one month ago. Any proceedings so far?

    b

     
  • Anonymous - 2010-02-28

    hey alper, I really really want to contribute stuff, that the development runs further quickly, especially with regard on this umlaut-problems, but I'm not into this svn and c-programming and filesystem stuff, just an advanced user I would say. Anyway, what would be the next task? Make the whole source code unicode-compatible or what? Can I do anything like convert plain text files from ASCII to UTF8?

    cheers benny

     
  • Anonymous - 2010-03-28

    ok, 2nd month without messages or updates. yet any proceedings? how can I help pushing this forward?

     
  • Anonymous - 2010-04-22

    after 3rd month without any message and proceedings I have to ask… Alper, are you actually still alive and what about this project? Is the problem with the umlauts a bigger one? Thought it should'n be this difficult to change the location settings on your linux machine to utf8, but it seems so.

    benny

     
  • Anonymous - 2010-05-09

    After some more Testing I expierenced some interesting things…

    First I uninstalled fuse-ext2 and installed the Paragon ExtFS Driver. This wasn't either able to read my files with the Umlauts. But since it has real 'read and write' support i was able to change the file names and bring them back to life. Then i changed the name back to the original umlaut variant and was still able to access the files. So this all made me think the problem could be a Mac-specific one according to interpreting utf8 in general. But when I mounted the drive to my linux machine, all files had the right names, so obviously no real codepage conversion problem.

    After this I tried the same thing with the fuse-ext2 driver with activated rw-support. Uninstalled Paragon ExtFS and reinstalled fuse-ext2. Of course I could bring the files back to life removing the umlauts. Same as before. But trying the to rename them back to the names with umlauts I was not  able to access them again.

    cheers benny




     
  • Pavel Vondricka

    Pavel Vondricka - 2010-05-10

    Yes, the problem only occurs in GUI application. I can access the files without problems in the terminal and copy/open them in the Midnight Commander. However, no GUI application can access the files.
    And yes, it is problem of all characters beyond ASCII.

     
  • Ben Zwak

    Ben Zwak - 2010-05-27

    Hi all

    I had similar problems with a ext2 disk. German umlauts were only visible as ? and were not to copy.
    I uninstalled fuse-ext2 and installed the Paragon ExtFS Driver. Same problem first also. But files where accessible in terminal. Then I changed the terminal settings: Terminal/Einstellungen/Erweitert/Zeichen-Codierung to ISO latin1. Now I was able to see the files with correct german umlauts.
    Then I used the convmv tool to change file names to UTF8 and now they are correct even in finder.
    http://j3e.de/linux/convmv/

    Cheers,

    Ben

     
  • Ben Zwak

    Ben Zwak - 2010-05-27

    Just realised that finder shows the files with correct names, but does not copy them. Like wanthalf said, it seems to be a GUI app problem. But copying from terminal worked as expected.

     
  • Anonymous - 2010-05-30

    Yes, I can confirm that copying in terminal now also works for me.

    benny

     
  • Anonymous - 2011-02-22

    copying in terminal only works if I drag&drop the files there

    meanwhile I found out, that it really likely has something to do with the Normalization Form for multibyte characters in unicode.
    http://www.unicode.org/reports/tr15/#Norm_Forms

    When I drag the same File created either by Mac or Linux to the browser address line I get two different results:

    /Volumes/Untitled/büro
    Linux encoded -> file:///Volumes/Untitled/b%C3%BCro/ -> ü = U+00FC (LATIN SMALL LETTER U WITH DIAERESIS)
    Mac encoded -> file:///Volumes/Untitled/bu%CC%88ro/ -> ü = U+0075 und U+0308 (LATIN SMALL LETTER U + COMBINING DIAERESIS)

    cheers benny

     
  • Anonymous - 2011-02-22

    found a operable solution.

    Speaking of cross-platform interoperability, Mac OS X has a strange way of handling Unicode-encoded file names. Linux and most other Unix-like OS use the C normalization form (NFC) for encoding to UTF-8, while OS X uses NFD. Convmv can convert file names between these two standards with the —nfc and —nfd switches.

    http://xpt.sourceforge.net/techdocs/nix/wp/fmt/fmt03-UnicodeConverting/single/

     
1 2 > >> (Page 1 of 2)

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks