Fuller joystick no longer works

  • Phil Reynolds

    Phil Reynolds - 2011-01-15

    In the fairly recent past, a Fuller joystick emulation was added to fuse, and it worked. However, some time between then and revision 4259, it appears that it no longer works. I have tried to test it with The Pyramid and Alchemist, and apart from some random left, right and fire, it seems to do nothing - certainly, it doesn't respond to the stick.

    This is not a huge problem as I don't know of any program that supports Fuller but not also either Kempston or Cursor. However, it would be nice to have it working.

  • Philip Kendall

    Philip Kendall - 2011-01-15

    Works for me.

    $ ./fuse -fuller Pyramid.tzx

    When Fuse starts, select a joystick (I did Options / Joysticks / Keyboard and then selected Fuller from the radio buttons on the left as I don't have a real joystick).

    In-game, press 1 to select Fuller.

    QAOPspace now work as up-down-left-right-fire for me.

  • Phil Reynolds

    Phil Reynolds - 2011-01-15

    Ah, that's sorted it - I'd forgotten there was another option to enable.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks