#14 unable to compile fuppes 673 on FreeBSD 7.2

open
nobody
5
2010-06-16
2010-06-16
Anonymous
No

I download the latest version from SVN.
CD to directory.
run "autoreconf -vfi" = success
run "./configure" = success
run "make":
lib/Plugins/Plugin.cpp: In member function 'bool CPluginMgr::init_plugin(std::string)':
lib/Plugins/Plugin.cpp:129: error: invalid conversion from 'const char*' to 'char*'
lib/Plugins/Plugin.cpp:138: error: invalid conversion from 'const char*' to 'char*'
lib/Plugins/Plugin.cpp: In static member function 'static void CPlugin::logCb(void*, int, const char*, int, const char*, ...)':
lib/Plugins/Plugin.cpp:593: warning: unused variable 'info'
*** Error code 1

Stop in /tmp/fuppes/src.
*** Error code 1

uname -v
FreeBSD 7.3-RELEASE-p1 #0: Wed May 26 04:29:05 UTC 2010 root@i386-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC

I am a newbie with all of this so please let me know how to resolve this.

Discussion

  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2010-06-16
    • labels: --> Install Problem (example)
     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2010-07-12

    This item can be closed.

    I resolved this issue by editting the file and putting "const" in front of "char" on line #129.

    Also, I commented out the section around line #593, so it compiled fine.

    Anyways, I am using version 675 now and it compiled and installed fine.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks