fuppes-win fails to start

  • Matt Schmidt

    Matt Schmidt - 2009-11-17

    I have been using FUPPES for the past few years, and until a recent computer crash which caused a reinstall, have had zero problems with FUPPES.
    I'm using Win XP with a PS3.
    I've installed fuppes-SVN-640-win32 and the shortcut lauches a command line version of the app.  When I try fuppes-win.exe, nothing happens. 
    I CAN stream and watch/listen via the PS3, so my question is what happened to the old GUI version?
    Why does the command line version only work?

    Thanks for an otherwise amazing program!

  • Robert Massaioli

    Hi, happy to help but just don't make a bug and forum post that are .

    I am more than willing to help but could you start by making a log file for us to read through and post it on a gist or pastie? Or email it to me. Thanks. You can do this via the command line using:

        -log-file /path/to/log.file

    As can be seen on the [. Thanks for your time and I hope you have been enjoying fuppes and will continue to.

      : https://sourceforge.net/tracker/?func=detail&atid=751214&aid=2898880&group_id=141999
      : http://fuppes.ulrich-voelkel.de/wiki/index.php?title=Command_line_parameters](http://en.wikipedia.org/wiki/Special:Search?search=%5B2%5D.+Thanks+for+your+time+and+I+hope+you+have+been+enjoying+fuppes+and+will+continue+to.%0A%0A%0A++%5B1%5D%3A+%5Burl%5Dhttps%3A%2F%2Fsourceforge.net%2Ftracker%2F%3Ffunc%3Ddetail%26atid%3D751214%26aid%3D2898880%26group_id%3D141999%5B%2Furl%5D%0A++%5B2%5D%3A+%5Burl%5Dhttp%3A%2F%2Ffuppes.ulrich-voelkel.de%2Fwiki%2Findex.php%3Ftitle%3DCommand_line_parameters%5B%2Furl%5D)

  • Matt Schmidt

    Matt Schmidt - 2009-11-17

    so I tried the "fuppes-win.exe" with the above and nothing happened.  So O tried just fuppes.exe -log-file "C:\Prog . . .   and I got the following in the log file:
                FUPPES - 0.640
        the Free UPnP Entertainment Service

    failed to initialize sqlite database plugin.

    strange, I would have assumed that with no database, there would be no browsing via the PS3?
    any thoughts?

  • Robert Massaioli

    Well I have one (sorry for the slow reply). I normally run fuppes on a Linux machine but the problem sounds similar. The usual cause of that error is that fuppes cannot find the right sqlite3 database plugin. On windows the plugin file is "sqlite3.dll". Search your computer for that file. If it does not exist then that is your problem and well figure out what went wrong from there. If it does exist then tell fuppes where it is by saying:

        fuppes.exe -log-file somefile -plugin-dir C:\Dir\That\Holds\PluginDLL\

    And that should do the trick. Either way let me know that the results are (and what is inside the log file now if you find the elusive dll).

  • Robert Massaioli

    Actually this does not work. I am trying to recompile it on my machine now and if a problem still exists then it will become a bug report. Thanks for pointing this out. I will try and fix it soon.

  • Laempi

    Laempi - 2009-12-05

    I've got the same Problem here on my machine, and I think I can add some more detail. I'm running Win XP SP3 and I also can't start fuppes-win.exe  

    Whenever  I try, I see the Tray Icon pop up, but disappear immediately. Fuppes.exe is working, if started directly or from a link (ie from the start menu). If I try to run it from a dos box it fails with the above mentioned error (failed to initialize sqlite …)   
    This means to use commandline parameters you have to create a link, pointing to fuppes.exe and edit it, appending the commandline parameters. This way I can increase the loglevel an see the logs in the command-window opened (and I'm shure could also create a logfile). I Tried the same thing with fuppes-win.exe, but it does not seem to take any commandline parameters.  
    Seems to me like under windows gui applications are not designed to give any commandline output.  
    Please fix this Problem asap, or if fixed yet release new windows binaries. 

    Besides, thank you for this nice Program!

  • Art Pina

    Art Pina - 2010-08-23

    I should start a new thread, but I don't know how!
    Anyways, I built FUPPES - 0.675 from the SVN site and it built without any problems, following the basic information on the authors web site. However, it won't run. I get,
    Shared (Base) Config File:/etc/fuppes/fuppes.cfg
      failed to initialize sqlite3 database plugin.
      error opening database sqlite3
    I'm running CYGWIN_NT-6.1-WOW64 Server2 1.7.1(0.218/5/3) 2009-12-07 11:48 i686 Cygwin under Windows 7 Professional.
    I built FUPPES because the 0.660 stable release does not work with my Sony BX57, so I thought I'd tweak the source if I had any problems with the current development code, but I can't even get it to run after I built it.


Log in to post a comment.