Need help for configuration for mkv on PS3

  • ultratoto14

    ultratoto14 - 2008-01-10

    Some mkvs are not playable (transcoded to MP4 or vob) as the main h264 video does not respect the maximum configuration for PS3.

    I used this command line to transcode the mkv to mpeg2

    ffmpeg.exe -r 23.976 -i movie.mkv -vcodec mpeg2video -sameq -acodec copy -f vob -copyts -y movie.mpg

    How can i configure fuppes to do this on the fly ?

    Thanks in advance.

    • GiantRabbit

      GiantRabbit - 2008-01-12

      I'm still experimenting, but so far transcoding to MPEG-2 works:

      Put this in your global "file_settings":
      <file ext="mkv">

      Put this one in your PS3 device  "file_settings":
      <file ext="mkv">
          <transcode enabled="true">

      Some notes:
      - Seeking doesn't work (very annoying :p), so no fast forward etc.
      - Fuppes is gonna eat 1 CPU away (eq. 100% cpu usage)
      But... hey, it works.

    • Sander

      Sander - 2008-01-12

      Is there any way to stream the AC3 audio from the original mkv file?

    • Chris

      Chris - 2008-01-13

      Thanks for the cfg post!

      I understand that it's highly experimental at the moment, but is there any way to transcode the internal subtitle streams along with the video?

    • ultratoto14

      ultratoto14 - 2008-01-15

      Thank you, i will test but i dont want to loose my 5.1 audio. An option like copy in codec will be very good.

    • ultratoto14

      ultratoto14 - 2008-01-15

      Tried this but fuppes crashes on every file i tested. I'm under windows vista 32. When i launch fuppes via the cmdline, set the log to extended, i see that fuppes parse my mkv and see the properties then crash.

      • Chris

        Chris - 2008-01-15

        What is the video/audio encoded in? Are all your mkv files from the same source? I'm not sure what fuppes uses to transcode on windows.

    • Gunder

      Gunder - 2008-01-16

      What kind of computer are you running fuppes on?

      I just have and old AMD Athlon 1.7 GHz or something like that as a server, and when I try to transcode mkv fuppes gives me this:

      == lib/HTTP/HTTPMessage.cpp (446) :: Wed Jan 16 18:47:48 2008 ==
      we are sending faster then we can transcode!
        try     : 20/20
        length  : 0
        position: 0
        size    : 1048576
        rest    : 0
      delaying send-process!

      Too old computer, or is my config wrong?


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks