why PS3 only sees fuppes server occationally

  • juha pahkala

    juha pahkala - 2007-10-18


    I recently purchased a PS3 and was very surprised and happy to learn about upnp and the PS3 support for that after tinkering with my PS3. And since I didn't know anything about upnp, I googled a while and decided to try out fuppes on my ubuntu gutsy server to serve my multimedia sharing needs.

    After a while of trial and error I had a fuppes server up & running and the fuppes database populated with my multimedia files. I fired up my PS3 and hit the 'search for servers...' icon, but it didn't find any. Tried different things until got fed up and started to play a game. Then after quitting the game I found to my surprise the fuppes server visible and functional on my PS3 (at least for playing music).

    It stayed visible until I accidentally pressed the 'search for servers...' button again, after which I lost the connection to the server and didn't find it again. Now a few days later I've learned this behaviour to be more a rule than an exception. My fuppes is visible to my PS3 in seemingly random ways.

    Now my question: Is this behaviour to be expected from upnp protocol in general or a fuppes server in particular? Or is it an indication of a mis-configured fuppes installation? If the latter (as I suspect), are there any obvious suggestions as to what I should try in order to make fuppes work in a relaiable matter?

    TIA, juhis

    • juha pahkala

      juha pahkala - 2007-10-19

      Me again,

      First of all, I'm using the latest version (SVN-549)

      Got a little further yesterday. Found out that if I press a (alive notify) on the fuppes console, my PS3 instantly recognizes the fuppes server. But I'm a bit confused as to what to expect.

      I guess my main question is, that how is this supposed to work, ie. do people have upnp setups where the client instantly recognizes the server automatically? It seems a little weird, that I have to emit a signal from the server to make it visible. And I don't understand why my PS3 doesn't see the server when I try to search media servers from the PS3. Could this be some sort of network problem (shouldn't, since my network seems to work fine)?

      As a quick fix, is it possible to make fuppes send these alive notifications more frequently, like every five seconds?

      tia, juhis

    • Ulrich Völkel

      Ulrich Völkel - 2007-10-19

      It seems that fuppes does not receive the m-search messages sent by the PS3.
      Can you please set the loglevel to "debug" and them do a "sever search" on your PS3.

      - Uli

    • juha pahkala

      juha pahkala - 2007-10-19

      Hi Ulrich,

      Thanks for the reply, so evidently the current behavior is not how upnp is supposed to work, this is good news.

      I'll do that, will get back to you once I get home and am able to test this.

      tia, juhis

    • juha pahkala

      juha pahkala - 2007-10-21


      So the result from trying to search mediaservers in PS3 with log-level = debug in fuppes is not a good one, nothing got printed on the fuppes console. I guess this is a bit worrysome, or what? If I press the 'a' key, a lot of stuff is printed on the console, would that be helpful to you? Or some other information I could provide?

      Thanks, juhis

    • Gunder

      Gunder - 2008-01-16

      Anyone else has this problem? I also have to press "a" so the PS3 "sees" the Fuppes after some time of inactivity. Is there any way to put the "alive notify" in the webinterface? Then I could get a script to call that page every five min or something...

      Stein G.

    • Ulrich Völkel

      Ulrich Völkel - 2008-01-19

      Can you please check how long it takes from pressing "a" untill fuppes disappears.

      fuppes sends the alive messages every 15 mins (as described in the UPnP spec).
      The fact that pressing "a" works shows that the messages are received by the PS3 so it's not a network/routing problem.

      You are running Windows, right!?

      - Uli

    • Gunder

      Gunder - 2008-01-20

      No, I'm running CentOS 4.5(Linux 2.6.9-67.0.1.EL), and Fuppes 586(but I've had the same problem with every versions of Fuppes.

      And I don't think the problem is that fuppes disappears, because it looks like after I have pressd "a" the PS3 will find it untill I turn my PS3 off.

      It looks like the problem is that Fuppes dosen't get the "search" from the PS3. Because when I turn on the PS3 it finds all other media server at once, but never fuppes. In log level 3 fuppes never gets any input from the PS3. If I search for Mediaservers on the PS3 it's the same, it finds all others at once, but never fuppes, and nothing comes out in the log for fuppes either.

      But when I press "a", or if fuppes is startet when the PS3 is on, it's found by the PS3 right away.

      Stein Gunder

    • Anne

      Anne - 2008-01-22

      When I first started playing with fuppes it did the same thing, but later it corrected itself. I'm sorry I do not know why, but now my fuppes (576 & 584) never disappear from my PS3.

      I think it might have worked itself out when I d/l ed a cfg-file from this forum. Sorry to be of so little help.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks