The --disable-transcoding cann't be used.

Help
2006-12-13
2013-04-25
  • chung -hsing ,chen

    Hi All,

    I meet a problem when to use the option on configure. I will see the following message. 

    Transcoding disabled
    The encoding library LAME was not found
    Please install the LAME library
    and run ./configure again

    But, when I remove the option. The configure result seems ok. 

    Transcoding enabled
    lame : yes
    vorbis: yes
    mpc : yes
    flac : yes

    So, what's happen? I don't know what's the real meaning of this option. But if my device is a low power platform, sould I use this option? Sorry, too many questions... Thanks

    Tonny

     
    • chung -hsing ,chen

      Sorry! forget to post the version. The version is 0.5.4 .In case one, I make the source code will get many error messages at  /Transcoding/TranscodingCache.cpp . I had modified the code and it is work now. But I don't sure the modifiction is right. So, please give me a patch or comment. Thanks.
      Tonny

       
    • Ulrich Völkel

      Ulrich Völkel - 2006-12-15

      the --disable-transcoding option disables all transcoding functions. If compiled with that option fuppes will not check for any transcoding lib at runtime. mpc, flac & ogg are still shared but are not touched by fuppes.

      And yes thanks, I just forgot to test the option in 0.5.4. With the option I also get the errors.

      Anyway, the option will be removed soon. I will add some options to the fuppes configfile that let you select wich filetypes are shown and if it should be transcoded or not.

      If you need it I can make you a patch. If not the next version will fix it.

      big thanks for reporting this one!

      uli

       
    • chung -hsing ,chen

      Hi Uli,

      Thanks. I need your patch for my referance. I had let the option work, but I didn't should the modifiction is correct.My email account is tonnychen@so-net.net.tw.

      Tonny

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks