Fuppes gives blank web interface

Help
2009-05-23
2013-04-25
  • Logan Crouch

    Logan Crouch - 2009-05-23

    So I've got fuppes running on an Ubuntu 9.04 box that I'm using as a headless closet server.  I've followed the wiki to the letter and got it compiled and installed, but I've run into a strange problem I can't figure out.  Whenever I have fuppes start using init.d running fuppesd, I get a 404 error when I try and access it's webpage (I have it set to use 41592 as the port but I have also tried 50000 and 50505), when I switched init.d to use fuppes (the normal one) or run it myself and point it at the config files, I no longer get a 404 but I get a blank page.  When I run fuppes with NO config file and just let it go where it may, I am able to get the web interface but only on whatever random port it picks.

    I'm pretty much at my wit's end, I though I had everything configured but clearly I fouled up somewhere.  Ideas?

    Here's the network portion of my fuppes.cfg file

      <network>
        <!--empty = automatic detection-->
        <interface>eth0</interface>
        <!--empty or 0 = random port-->
        <http_port>41952</http_port>
        <!--list of ip addresses allowed to access fuppes. if empty all ips are allowed-->
        <allowed_ips>
          <ip></ip>
        </allowed_ips>
      </network>

     
  • Robert Massaioli

    Can you do me a favour and try and remove the <ip></ip> line because I think what this configure file says is that the only valid ip adress is the empty one. If it still does not work with that line removed then post here again and i will take a closer look at the source code.

     
  • Robert Massaioli

    Annoying formatting. Please remove the &lt;ip&gt;&lt;/ip&gt; that's what is missing from the statement above.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks