Xbox 360 Can't Connect to FUPPES (WinXP)

Help
Metsf1
2009-11-08
2013-04-25
  • Metsf1

    Metsf1 - 2009-11-08

    Whenever I try to connect to the FUPPES source in my 360, the connection times out. 

    I've got FUPPES installed and I can use the web interface to configure the service.  I forwarded the ports on my router and I made sure to unblock the ports and the program in windows firewall.  I added the ip's in the cfg file.  I made all of the 360-specific adjustments necessary in fuppes.cfg and vfolder.cfg too.  When I turn on my 360 and go to the Video Library, the xbox sees FUPPES 0.640 : 1 as a source.  However, when I click on it, it says "connecting" and then times out.

    Any ideas on how to fix this would be much appreciated

     
  • Robert Massaioli

    You seem to have done everything correctly and if your xbox can see fuppes then that is a good sign. It means that you are close to having everything right. Lets try a few things to debug this:

    * Please give me your fuppes.cfg and vfolder.cfg files. Please provide them by placing them in a paste, gist or other file host. Or send me them in an email. I think you have done it correctly but two eyes on the one problem never hurt.
    * Should everything prove to be correct then please fun fuppes with the following options: -log-level 3 -log-file fuppesLog.log

    Provide all of those files: fuppes.cfg, vfolder.cfg and fuppesLog.log and well try and solve it from there.

     
  • Robert Massaioli

    I have taken a look at your fuppes.cfg and your vfolder.cfg and I have two suggestions:

    Firstly, In the vfolder.cfg change the:

        <vfolder_layout device="default" enabled="false">

    To be:

        <vfolder_layout device="default" enabled="true">

    Then if that does not work (without changing it back) edit your fuppes.cfg file so that the corresponding interface line looks empty like this:

        <interface></interface>

    That way know that the folders are being generated and that that the right interface is being found. If that fails then I will have to trawl properly through the log file which could take a little bit of time.

     
  • Metsf1

    Metsf1 - 2009-11-08

    Thanks for the suggestions robert.  Unfortunately, the problem still persists :(  Hopefully the log will have some clues - I'll look through it too.  No big rush.

     
  • Metsf1

    Metsf1 - 2009-11-09

    Just for the sake of troubleshooting, I hooked up my laptop directly to my xbox 360 with a cat5e cable to bypass my router to make sure it wasn't a port being blocked or a bad wifi signal.  When I put in the right IP address in fuppes.cfg, sure enough, xbox saw the FUPPES 0.640 : 1 source upnp server, but I still get connection failed.

     
  • Metsf1

    Metsf1 - 2009-11-13

    Hi Robert, not sure if you've had a chance to look at the log yet.

    I noticed in the log that fuppes is using all kinds of ports.  In my cfg file I specified port 5090, and that's the only port I've forwarded in my router.  What ports should I be forwarding/what ports does fuppes operate on?

     
  • Robert Massaioli

    Sorry for the delayed response. All kinds of ports is okay. Fuppes needs to do alot of different things on the network. As for port forwarding, I actually don't do any and it works just fine for me. What happens when you remove your port forwarding options?

    Also, what are you trying to play through fuppes? Please make sure that the file can play on your XBox (by putting it on a usb and plugging it in) so that we know that the XBox can play the file. I know that a few .avi files will not play on my XBox.

    Other than that, what OS are you running on? Windows or Unix based?

     
  • Metsf1

    Metsf1 - 2009-11-15

    No problem.  There's no port issue, I shouldn't have even mentioned it, as I did the test above and it still doesn't work.  I don't think the problem is with the file format - the xbox can't even connect to browse the files.  I'm running Windows XP (all the latest updates).

     
  • Robert Massaioli

    I'm not sure what the problem is to be honest. I'm about to setup fuppes on windows soon so maybe I'll be able to help more then. It's frustrating me that I cannot figure out what is going wrong. I think I need to add better logging into the project so that is going on the TODO list now.

    Basically any more information you can give might help; thought the only think that i noticed is that you seemed to have an odd ip address. Most home networks have 192.168.0.* but your computer seemed to be identifying as 192.168.1.*? What ip address did your router assign to the computer that is currently running fuppes?

    Thanks.

     
  • Metsf1

    Metsf1 - 2009-11-20

    Thanks for the help Robert, I've done plenty of software development before so I understand.

    The router assigned 192.168.1.3 to the computer running fuppes and 192.168.1.4 to the xbox 360.  I'd say it could be a router problem, but I actually went ahead and plugged the 360 into the ethernet port of my computer, bypassing the router completely.  It recognized fuppes, but again, wouldn't connect.

    I might try it under another computer and/or ubuntu to see if that works.

    I can post some system specs of things I've tried it on if you want.    I can record some logs, too, if you need.

    Thanks for the help - throw any other suggestions my way.

     
  • stimulate

    stimulate - 2009-11-20

    Have you seen this link about Xbox 360?  I don't use one but found this instructive web site.

    http://ubuntuforums.org/showthread.php?t=597650

     
  • Metsf1

    Metsf1 - 2009-12-06

    Thanks, I tried the config on that link too, still no luck.  It sees fuppes and recognizes it as a computer, but again, when I try to browse it it always gives a connection time out.

     
  • Bloodycelt

    Bloodycelt - 2010-01-01

    If it helps any I have the same problem running
    version     : 0.659
      hostname    : navi.local
      OS          : Darwin 10.2.0
      build at    : Dec 31 2009 15:35:43
      build with  : 4.2.1 (Apple Inc. build 5646)

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks