After a recent Debian upgrade, I get segmentation faults most times I start fuppes. I've tried this with build 657 as well as the latest build (692), both rebuilt from source on the current system. gdb shows:

Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
            FUPPES - 0.692
    the Free UPnP Entertainment Service
      http://fuppes.ulrich-voelkel.de

Program received signal SIGSEGV, Segmentation fault.

0xb7a95357 in memcpy () from /lib/i386-linux-gnu/libc.so.6

Or sometimes:

0xb7cc68d5 in RegEx::Match(int) () from /usr/lib/libfuppes.so.0

Once every few times, it actually starts up.

Any suggestions how to get fuppes working again?