Ian Macdonald - 2010-08-03

I started with the stable release but every time I tried to access media on Fuppes it would crash, I switched to 675, and followed http://matthewm.boedicker.org/doc/installing-fuppes-on-ubuntu-10-04-lucid-lynx.html but couldn't get it to save config files. So ended up manually editing the config files to get everything up and running.
I added

    <file ext="m4v">
      <type>VIDEO_ITEM</type>
      <mime_type>video/mp4</mime_type>
    </file>

to ~/.fuppes/devices/default.cfg and can play back my video files.

So the only thing left that I need to get to work is m4a files. My samsung will play back mp3 files so I am trying to get the following to work

    <file ext="m4a">
          <type>AUDIO_ITEM</type>
          <mime_type>audio/mp4</mime_type>
          <transcode enabled="false">
            <ext>mp3</ext>
            <mime_type>audio/mpeg</mime_type>
            <dlna>MP3</dlna>
            <http_encoding>chunked</http_encoding>
            <decoder>faad</decoder>
            <encoder>lame</encoder>
            <bitrate>192</bitrate>
            <samplerate>44100</samplerate>
          </transcode>
    </file>

but I keep getting errors about libfaad.so.0 not existing. I tried creating a symbolic link to libfaad.so.2 but that didn't solve the problem.

I had a look and it seems like the function names have changed from  faac* to NeAAC* eg  faacDecSetConfiguration   NeAACDecSetConfiguration.

Does anyone have any suggestion on how to get m4a files to transcode?