Ubuntu packages available for testing

James Lee
1 2 > >> (Page 1 of 2)
  • James Lee

    James Lee - 2008-01-19

    Hello all,

    I've made some fuppes packages for Ubuntu Gutsy (Hardy packages will be available soon).  They contain fuppes SVN-578 with all audio and video transcoding enabled and should pull in all the needed dependencies.  The Gnome panel isn't enabled, as I'd like this to install without too many dependencies on Kubuntu as well.  I'm trying to get fuppes packaged up in time for inclusion in Ubuntu 8.04, so it would be great if people could test these out.

    Add the following repository, and install the "fuppes" package.  Or if you don't want to add the repository, just manually download the .deb file from it and install it (all the dependencies it pulls in are from the official Ubuntu Gutsy repositories).

    deb http://ppa.launchpad.net/james-lee/ubuntu gutsy main

    Please post any feedback on this thread, thanks.


    • Avi Schwartz

      Avi Schwartz - 2008-01-19

      Hi James,

      When I try to install it I get the following error:

      The following packages have unmet dependencies:
        fuppes: Depends: libfaad-0 but it is not installable
      E: Broken packages


    • James Lee

      James Lee - 2008-01-20

      Oops, apologies for this.  libfaad2-0 got renamed to libfaad-0 in in hardy and I'd originally built against hardy.  I've fixed the gutsy package now - it should hopefully be working (once it's made it's way through the PPA build queue).

      The ~gutsy5 version of the package should be in that repository in about an hour or so once it's been built.

      Thanks for trying this out.

      • Avi Schwartz

        Avi Schwartz - 2008-01-20

        This one worked indeed.  Since I had already all the dependencies installed from an old installation of fuppes, I cannot verify that all the dependencies are correctly defined.

        Also, it would be nice to have a script installed in /etc/init.d so that fuppes could be started automatically.

        One question though.  My PS3 was able to play the MP3's I have (very few) but it seems that transcoding of FLAC (99.9% of my collection) to MP3 does not or does not work correctly since the PS3 does not recognize it.  This may be a fuppes issue though and not this build.

        Thanks for putting the package together!


    • Avi Schwartz

      Avi Schwartz - 2008-01-20

      Never mind about the flac transcoding.  I found another post explaining how to transcode flac to PCM and it now works fine.  Wow, this is great!


    • James Lee

      James Lee - 2008-01-20

      Thanks for testing and confirming this works on your setup.

      Has anyone tested this who hadn't previously installed fuppes and all its dependencies?  I just want to make sure that all necessary packages are pulled in...

    • spartan.ii.117

      spartan.ii.117 - 2008-01-20

      I actually found your debs before i found this forum, but here goes: it pulled in the one remaining dependency, and seems to work fine, although i cant for the life of me seem to get this thing to talk to my 360. (fuppes sees it, but i cant connect.)

    • James Lee

      James Lee - 2008-01-21

      Sounds like the packaging is working then.

      In terms of your Xbox 360 not connecting to it, have you double checked your config files against the settings suggested in the wiki?  In particular, make sure that Xbox 360 support is enabled in the main fuppes config file (it isn't by default).

    • spartan.ii.117

      spartan.ii.117 - 2008-01-21

      i got the general enabling of it raather quickly, but where is this wiki you speak of?

    • James Lee

      James Lee - 2008-01-21

      The fuppes wiki, which is linked to from the main fuppes website: http://fuppes.ulrich-voelkel.de/wiki/index.php/Main_Page

    • James Lee

      James Lee - 2008-01-23

      Has anyone who didn't previously have ffmpeg etc. installed tried this package with a setup that requires video transcoding?

      I'm just pulling in the ffmpeg libraries from the standard ubuntu archive, and just wanted to check whether they actually worked here (my setup doesn't use transcoding, as I have an Xbox 360).

    • arrow

      arrow - 2008-01-23

      I'm running kubuntu and most of the dependencies seemed to be installed before I installed fuppes using your package. One weird thing though... fuppes says "no decoding library found. Transcoding disabled!." I have ffmpeg, lame, etc, so I figure it should work. Any idea why transcoding is not working?

    • arrow

      arrow - 2008-01-23

      Note I'm also having trouble playing mp3's from my ps3. From the fuppes end it is saying "error initializing audio decoder."

    • James Lee

      James Lee - 2008-01-26

      Yes, I think the problem here is that the version of ffmpeg in the Ubuntu repositories is compiler without support for the non-free codecs (mp3, aac, xvid, h.264, ...).  This means that fuppes is unable to do any transcoding.

      Unfortunately I don't think there's really a whole lot that can be done about this other than either:
      1) Changing the version of ffmpeg in the Ubuntu repo to enable non-free codecs - not going to happen.
      2) Adding an alternative version of ffmpeg with support for non-free codecs to the ubuntu repository - not easy to do.
      3) Disable transcoding support in the ubuntu package of fuppes.

      I'm therefore going with option 3.  I'll upload updated versions of fuppes with transcoding support disabled to my repositories (gutsy and hardy).  This is a bit of a shame, but I'd imagine that the majority of people probably don't use transcoding anyway now that the latest Xbox 360 and PS3 firmwares have added DivX support...?

    • Ulrich Völkel

      Ulrich Völkel - 2008-01-26

      > Yes, I think the problem here is that the version of ffmpeg in the Ubuntu repositories is compiler without support for the non-free codecs (mp3, aac, xvid, h.264, ...). This means that fuppes is unable to do any transcoding.

      No, that's not right. ffmpeg (resp. libavformat) is used for metadata extraction from video files and video transcoding but not for any audio transcoding.

      All audio de-/encoder libraries are loaded at runtime. So if you build the package with lame support and lame is not available on the user's system fuppes will run fine but without a mp3 encoder.

      here is a list of the de-/encoders and their libs

        ogg  - libvorbisfile
        mpc  - libmpcdec
        flac - libFLAC
        mp3  - libmad
        aac  - libfaad
        m4a  - libmp4ff

        mp3 - liblame
        mp2 - libtwolame
        wav & pcm - build in

      - Uli

    • James Lee

      James Lee - 2008-01-27


      OK, so I guess I just need to add a few more dependencies to pull in the appropriate libraries.

      Is there any point in requiring libavformat even if it hasn't been compiled with support for mp3, xvid, aac?  Will it still be able to get metadata from the file (for example from the avi container), and will that be used for anything useful by fuppes?

      FYI: the dependencies I now have are as follows (with the relevant runtime dependencies pulled in):
      Build-Depends: debhelper (>= 5), autotools-dev, libtool, libpcre3-dev, libxml2-dev, libsqlite3-dev, uuid-dev, libtag1-dev, liblame-dev, libmpcdec-dev, libfaad-dev, libflac-dev, libtwolame-dev, libavcodec-dev, libavformat-dev, libswscale-dev, libmagick++9-dev, libmad0-dev, libmp4v2-dev

      And I have no specific configure flags enabled.  Is that correct for a fuppes without video transcoding?

      • Avi Schwartz

        Avi Schwartz - 2008-01-27

        What about the Medibuntu repository (see http://www.medibuntu.org\)?  It is likely that the libraries there have the support for the formats that are missing from the official Ubuntu packages.

    • Ross Nye

      Ross Nye - 2008-01-27

      Thanks for creating the packages. They got me past the brick wall i'd gotten to in trying to compile the fuppes. I got past a couple myself (I didn't know you needed the -dev packages of the packages it was complaining about in order to compile), but was stuck on it not being able to find my Makefile.ln file (which was there).

      I've been playing around with fuppes on two machines. One machine, alpha, which I've been using for a while and the one I initially tried to compile fuppes on. The other machine, delta, is almost a fresh installation of Gusty 7.10 and has barely been touched bar adding the medibuntu repositories and adding an ISP hosted repo mirror. Alpha is also running Gusty 7.10, but has had flac and ffmpeg packages as well as others already installed (mainly as part of installing X360 Media Server). Both systems were updates using the Gnmome Update Manager prior to attempting installation.

      After adding your repo to my third party sources, fuppes showed up in Synaptic and I installed without a hitch on both systems, downloading a number of dependencies (33 I think on delta).

      I then ran fuppes from my terminal, it created ~/fuppes/fuppes.cfg. After a bit of stumling around I had an edited copy of fuppes.cfg and vfolder.cfg, which I downloaded from the Fuppes Wiki. At this point I was playing around with the config files on both machines trying get get it working with my XBox 360 (following other information contained in the wiki)

      I was mainly playing with delta as its my eventual aim to have that serving files and media to my network as well as sharing a couple of printers. Anyways I noticed that I was getting the same error arrow15 was. "error initializing audio decoder". This was not happening on alpha. pressing i revealed the decoders were indeed active on alpha, but not delta.

      I tried connecting the 360 to alpha instead and got it playing flac files, which it wasn't doing from delta. Who would have guessed since the audio decoder wasn't initialising right?

      After switching back to delta and enabling extended logging I discovered it was complaining about missing libFLAC. Last night in my attempts to get things working I'd "sudo apt-get install ffmpeg" and "sudo apt-get install flac". They were both installed along with a few dependencies. This was after i'd installed the fuppes package. To get rid of the error and finally enable transcoding of flac files I installed the libflac-dev package while browsing a search for flac in Synaptic this morning. This worked and now delta can serve flac files too. It was always listing the it flac files previously, but just gave and error when you tried to get the 360 to play them.

      I've also discovered the device settings and vfolder layouts included for the XBox 360 don't work with an up to date X360. A bit of editing of both fuppes.cfg and vfolders.fcg will get you there. I'm still trying to get pictures to videos display in a vfolder hierarchy, but they do work. Well most of them I still need to play around a bit more.

      To summerise a painfully long post I think you need to manually install the ffmpeg, flac and flac-dev in order to get transcoding to work properly if you install from this fuppes package. That's fine as not everyone is going to use it. Its just something people need to be aware of if they plan to use the packages. This is based upon my experience of course others may vary.


    • James Lee

      James Lee - 2008-01-27

      New packages uploaded for gutsy and hardy, which change the following:
      - disable video transcoding
      - add missing dependecies on libmad, libvorbis, and libmp4 which should get audio transcoding working

      You'll probably need to wait an hour or so for the upload to make it through the build system (look for hardy4 and gutsy7).

      Uli: if you have time, it would be really helpful if you could take a look at the package as it would be good for people to have working packages rather than needing to compile from scratch.  I'm trying to get this included in Ubuntu if possible.

      • Matthew Rasnake

        Matthew Rasnake - 2008-01-27

        Your efforts to provide packages are appreciated, and will certainly help new fuppes users to get setup more easily, however, without video transcoding enabled, they aren't of much use to me. Since the PS3's video support, even with DiVX, is still somewhat limited and twitchy, I've found it easier to simply transcode all instances of some filetypes that are theoretically partially supported (.mov, and .wmv mainly). If it were possible to provide alternate packages for video transcoding users, that would be a tremendous help. Until then, I'll just have to continue to build manually.

        perhaps two packages: fuppes, and fuppes-vt or something?

    • James Lee

      James Lee - 2008-01-27

      What I can probably do is have a fuppes package in the official ubuntu repository which doesn't have video transcoding enabled, and a fuppes package in the medibuntu repository which does have video transcoding enabled (as the ffmpeg version in medibuntu is compiled with support for all codecs I believe).

      I'm seeing some problems with the audio transcoding still however.  My hardy packages now seem to work for audio transcoding (fuppes no longer complains that there are no audio decoders), however my gutsy ones don't (despite being identical).  Now either there's something wrong with the gutsy version of some of those packages, or I somehow have something installed on hardy which is needed but not on my dependencies list.  I'll investigate (unless anyone has any ideas)?

    • James Lee

      James Lee - 2008-01-27

      Incidentally, my full dependency list is as follows.  Is there anything obviously missing, or obviously superfluous (bearing in mind that I'm trying to have audio transcoding, but not video transcoding capability)?

      Depends: libavcodec1d (>= 0.cvs20070307), libavformat1d (>= 0.cvs20070307), libavutil1d (>= 0.cvs20070307), libbz2-1.0, libc6 (>= 2.7-1), libfaad0, libflac8, libfreetype6 (>= 2.3.5), libgcc1 (>= 1:4.1.1-21), libice6 (>= 1:1.0.0), libjasper1 (>= 1.900.1), libjpeg62, liblame0, liblcms1 (>= 1.15-1), libmad0, libmagick++9c2a, libmagick9, libmp4v2-0, libmpcdec3, libogg0 (>= 1.1.3), libpcre3 (>= 6.0), libpng12-0 (>= 1.2.13-4), libraw1394-8, libsm6, libsqlite3-0 (>= 3.4.2), libstdc++6 (>= 4.2.1-4), libswscale1d (>= 0.cvs20070307), libtag1c2a (>= 1.4), libtheora0, libtiff4, libtwolame0, libuuid1, libvorbis0a (>= 1.2.0), libvorbisenc2 (>= 1.1.2), libvorbisfile3, libx11-6, libxext6, libxml2 (>= 2.6.27), libxt6, zlib1g (>= 1:

    • Ross Nye

      Ross Nye - 2008-01-28

      Once again thanks for the packages. I just upgraded (alpha) using the Ubuntu update manager without a hitch.

      What compiler options are you using?

      Flac transcoding works for me using your build with working a flac decoder installed, but. I haven't had the need as yet to do any video transcoding (I've just changed the mime_type in the xbox files_ettings for asf extension to get them to play)

      Does you build enable id tag reading using taglib? I remember seeing in a screen shot somewhere the status of such under "ImageMagick:  enabled" when you press 'i' in fuppes. I don't see it here. Is that because I am missing some lib's or because it's not enabled in the 1st place (or something else)?

      thanks again for your work on these packages.

    • Ross Nye

      Ross Nye - 2008-01-28

      scratch the q about taglib. web server on both machines confirms its enabled.

    • Zanth

      Zanth - 2008-04-05

      Good Day,

      Thanks for your efforts in getting a package together.  This is most helpful.  I'm currently having a problem with the libmagick++9c2a dependency and hardy heron. this library is not available and therefore I can't install fuppes.  I have libmagick9-dev installed but I can't find ++9c2a anywhere.

      Any ideas? 

      Thanks a bunch.

1 2 > >> (Page 1 of 2)

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks