675 no videos found and not able to play mp3s

  • Anonymous

    Anonymous - 2010-07-12

    I'm running fuppes 0.675 on FreeBSD 7.3.

    It compiles fine with "-without-libavformat".

    It installs fine.

    fuppes updates database and can list the objects on the website fine.

    My xbox360 is able to see the server but no videos are listed.  The message is "no videos found".

    My xbox360 sees the MP3 files but won't play them.

    what am I doing wrong?

  • Anonymous

    Anonymous - 2010-07-12

    when I hit the "play" button to play a MP3 file, the xbox360 just sits there.

    The title of the song is in the upper right corner with an icon to the right.  The icon is a circle with a line through it, i.e. "denied" or "prohibited".

  • Matt Moyles

    Matt Moyles - 2010-07-15

    I've been trying to setup the newest svn 675 on my 360 as well.  I can see the server in my 360 but no videos or music get listed.  Tried to update virtual container and rebuild database multiple times.

  • Mixx

    Mixx - 2010-08-13

    Me too. I can see some audio files but can't play them. Videos aren't even shown.

    Has anyone succeeded in getting svn 675 to work with xbox360?

  • anon1200

    anon1200 - 2010-08-18

    I'm running svn-675 on an Ubuntu 10.04 server. I configured with -disable-ffmpegthumbnailer to avoid a segfault,

    I'm primarily concerned with serving video to an XBox 360, so I haven't done any testing with audio. However, I was able to get video files (mostly mp4) to show up in the XBox 360. I verified that they actually play as well. I put the following into the default vfolder layout to accomplish this:

    <vfolder name="Video" id="2">
      <vfolder name="Folders" id="21">
        <folders filter="contains(videoItem)" />

    I also setup the default device with the following options:

    <!-- and some xbox friendly description_values -->

    However, while this should (and used to) produce a nice folder hierarchy, in SVN-675 this produces a flat listing of all available Videos. Looking at the code in VirtualContainerMgr.cpp it seems the code to generate folder containers has been broken/disabled.

  • Miika Hänninen

    Miika Hänninen - 2010-08-24

    I created a fix for the music problem. You can download the patch from the bug report I linked to in the previous post.

    You'll need to recompile fuppes for this. Just download the patch to the fuppes/src/plugins folder and apply the patch. Then compile as normal.

  • Mixx

    Mixx - 2010-09-01

    I managed to get my videos working as well. The patch already helped on the music stuff and now pictures and videos work as well.


    What I did:
    Added the mime types to xbox.cfg(in devices) as in previous versions:

        <file ext="mp3">
        <file ext="jpg">
        <file ext="avi">
        <file ext="mp4">

    But what really made the difference(I think) was that apparently the normal file detection only creates vfolder information for music. So I recreated the vfolder layout manually (v on terminal interface).

  • Miika Hänninen

    Miika Hänninen - 2010-09-01

    I added a new patch to the bug report which makes fuppes add videos and images to the vfolders.

    As I added created the fix, I also broke the music stuff. I started from clean 675 code and applied my patch. So either I accidentally broke something while creating the second patch, the second patch breaks the music stuff in some weird way or the first patch is not enough to fix the problem and I forgot to include that in the patch.

    Please test the new patch and tell me if it works for you. Also is the first patch working properly for you? You might want to start with a clean database when you apply the second patch, at least I got some weird errors where fuppes tried to insert instead of updating objects, which caused problems with the database. After I removed the database and restarted fuppes, it worked well.

  • Mixx

    Mixx - 2010-09-02

    The first patch is working properly for me.

    I'll try the new one to see if it works once I'm back home.

  • Miika Hänninen

    Miika Hänninen - 2010-09-02

    Both patches work for me on clean code (completely uninstalled fuppes, removed sources, did complete installation with the patches).

    I must have broken that in my code while working on the video fix.

    Now all that remains is getting the xbox to play transcoded video files…

    If anyone has working transcode settings I would appreciate it very much


Log in to post a comment.