unable to activate transcoding at compilation

Help
Mathieu
2009-06-25
2013-04-25
  • Mathieu

    Mathieu - 2009-06-25

    I try to build fuppes on a Debian testing system with debian-multimedia packages.

    I've installed the following packages from official debian repositories:

    subversion build-essential automake libtool libpcre3-dev pkg-config
    libxml2-dev libsqlite3-dev uuid-dev libmagick++9-dev libtag1-dev
    libsimage-dev libmpcdec-dev libfaad-dev libflac-dev libflac++-dev
    libmad0-dev libtwolame-dev

    Then following packages from debian-multimedia:

    libavformat-dev libavcodec-dev libavutils-dev libmp4v2-dev libmp3lame-dev ffmpeg

    After a svn checkout and an autoreconf, I try to configure fuppes:

    ./configure --enable-lame --enable-twolame --enable-mad --enable-faad --enable-libavformat --enable-mp4v2 --enable-video-transcoding --prefix=/usr

    First thing: 'enable-video-transcoding' isn't an option anymore but every documentations I've found says to use it...

    And the result of the configure is:

    ----------
      SUMMARY

      audio transcoding plugins
        encoder:
          lame       : yes
          twolame    : yes
          pcm/wav    : yes
        decoder:
          vorbis     : yes (libvorbisfile)
          mpc        : yes
          flac       : yes
          faad       : yes (aac/mp4/m4a)
          mad        : yes (mpeg Layer I, II & III)

      video transcoding plugins
        ffmpeg     : disabled

      image conversion/rescaling plugins
        ImageMagick: enabled  (Wand C-API)

      audio metadata extraction plugins
        taglib        : enabled  (mp3, ogg, flac & mpc)
        mpeg4ip/mp4v2 : disabled (mp4/m4a)

      image metadata extraction plugins
        Exiv2         : disabled
        ImageMagick   : enabled  (Wand C-API)
        simage        : enabled  (jpeg, png, gif, tiff, rgb, pic, tga, eps)

      video metadata extraction plugins
        libavformat   : disabled

      miscellaneous
        iconv      : enabled (charset conversion)
        uuid       : enabled
        inotify    : enabled
    ----------

    ffmpeg and libavformat are disabled but they're installed on my system. I don't know what I've done wrong.

    Have you a solution?

     
    • Mathieu

      Mathieu - 2009-06-27

      ok I've found...

      after my "svn co", I have to do a "make clean" and now the "./configure" run correctly

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks