Web server bugs? (r595)

Help
Ross Nye
2008-02-24
2013-04-25
  • Ross Nye

    Ross Nye - 2008-02-24

    I've noticed with r595 that on the status page of the web server the table headings of the Build Options and Device Settings are white text on a white background. This is because they are missing the inline styling that appears in the Database Status table; namely style="background-image: url(images/header-gradient-small.png); color: #FFFFFF;". I've seen this before with previous builds, but I don't think it happened with r593.

    Well for the last couple of hours I've managed to solve the above. I altered two files and rebuilt the fuppes.
    In ../fuppes/src/lib/Presentation/PresentationHandler.cpp line 151
    else if(ToLower(pMessage->GetRequest()).compare("/presentation/images/header-gradient.png") == 0) {
    It appears you missed the images directory in the path. (I've added it above).

    I also changed the file ../fuppes/src/lib/Presentation/style.css to reflect the following. I don't actually know what they were initially set to as I changed them a few time, but this is whats working now.

    title.background-image: url("/presentation/images/header-gradient.png");
    th.background-image: url("/presentation/images/header-gradient-small.png");

    I also changed the th.color to make sure it's working and my background now not only work, but my text is green (which is to be expected). Excellent. Shall I log a bug for this? I think so.

    I suppose the inline styling should also be removed from Presentation.cpp as the stylesheet definately takes care of all that.

    BTW Uli what do I need to do to actually get the changes made to style.css to be reflected be the web server, Currently I am:

    autoreconf -vfi
    ./configure ...
    make
    sudo checkinstall
    fuppes

    I wouldn't mind playing around with the stylesheet, (as the fonts are a bit small for me) and having to rebuild all the time would be painful. It would be great if you could make the stylesheet like the two existing config files and be parsed at startup. Just a thought.

    The other thing I have noticed is that the web server reports "Neither LAME nor TwoLame found. Transcoding disabled!". Yet the terminal says "lame: enabled" (and I have lame installed - well it runs from the shell)

    cheers

     
    • Ross Nye

      Ross Nye - 2008-02-24

      Bug report submitted for the white one white text (bug#1900866)

      Can someone else confirm that they get the same/different messages about lame for the web server?

       
      • Michael

        Michael - 2008-02-24

        I can confirm this transcoding message - behavior.

        My build options:
        iconv true
        uuid true
        taglib true
        imageMagick false
        libavformat (ffmpeg) true
        video transcoding (experimental) true
        lame true
        twolame false
        ogg/vorbis true
        musepack false
        flac true
        flac false

        general information:
          version     : SVN-r595
          hostname    : linux01
          OS          : Linux 2.6.22.17-0.1-default
          build at    : Feb 23 2008 14:47:34
          build with  : 4.2.1 (SUSE Linux)
          sqlite      : 3.4.1

        Regards,
        Michael

         

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks