can fuppes running on daemon

Help
kahomh2000
2006-12-05
2013-04-25
  • kahomh2000

    kahomh2000 - 2006-12-05

    when i run fuppes with background
    it seem doesn't work ....
    can i run fuppes in daemon

     
    • Ulrich Völkel

      Ulrich Völkel - 2006-12-05

      Yes, you can. Just append the parameter -d.

      Best regards,
      Uli

       
    • kahomh2000

      kahomh2000 - 2006-12-07

      thanks for help
      but when i use #./fuppes -d
      and "daemon mode" msg show up
      and than the process be kill ,"ps aux" can't see fuppes process
      what's wrrong with me , my os is Debian GNU/Linux 3.1 \n \l running on Mac G3
      can't fuppes support Powerpc platform

      Best regards

      kahom

       
    • Ulrich Völkel

      Ulrich Völkel - 2006-12-09

      fuppes should run on ppc. I tested it on a G4 iBook.
      I will check if the daemon mode causes problems on PPC.

      Does it run without problems for you when you don't use the deamon mode?

      regards,
      uli

       
    • kahomh2000

      kahomh2000 - 2006-12-09

      yes ...it's very well at console mode

      and i have meet an other problem
      when i use "nero show time 3.2.3.0" play media file
      the fuppes got killed ..it's so strange...
      i try so many time on different pc ... all same result
      fuppes process be killed ...i don't know why

      turely thanks for you help

      Kahom

       
    • kahomh2000

      kahomh2000 - 2006-12-13

      i find the reason, because fuppes use old cfg(0.5.3)
      i delete /root/.fuppes and restart fuppes in deamon mode
      it work find ...

      BR

      Kahom

       
    • Ulrich Völkel

      Ulrich Völkel - 2006-12-15

      Great! I just thougth it crashed when reading the config file so I started to implement loggin via syslog and the config will be checked before the daemon process is forked.

      Beware. For security reasons you should not run fuppes as root.

      regarding to the ShowTime crash I have no idea at the moment. As I don't have a Show Time to test I can't reproduce the error.
      Can you send me a stacktrace of the error? You know how to make one?

      uli

       
    • kahomh2000

      kahomh2000 - 2006-12-18

      ha ....i don't know how to do ??
      can you show me ^^

       
    • Ulrich Völkel

      Ulrich Völkel - 2006-12-26

      hello, sorry it took so long.

      firt of all you need the gdb.
      then get a clean copy of the fuppes sources

      $ tar -xvzf fuppes-0.5.4.tar.gz
      $ cd fuppes-0.5.4

      set the complier flags

      $ export CXXFLAGS="-O0 -g"
      (capital o and null)

      and then configure and build fuppes

      $ ./configure
      $ make

      start fuppes with gdb

      $ gdb src/fuppes

      you should see the gdb prompt

      (gdb)

      type

      (gdb) start

      will break at the first line in the main() function. then type

      (gdb) c

      to continue.
      reproduce the crash and write

      (gdb) bt

      to show the stacktrace.

      very big thanks for testing.
      best wishes,
      uli

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks