Starting on Linux

Help
2005-06-28
2012-12-07
  • Edward Mann

    Edward Mann - 2005-06-28

    How do you start FullSync on a linux machine. I have no idea on what to do. What commands do i run?

    Thanks.

     
    • Boromir

      Boromir - 2005-06-30

      - Download the file FullSyncInstaller.jar
      - run java -jar FullSyncInstaller.jar
      - install it where you want
      - run fullsyncdir/bin/fullsync.sh

      thats it.

       
    • yanto

      yanto - 2005-09-08

      Hi
      I follow your instruction but I received "Exception in thread Main" . Mu platform is Solaris 9. The same is happen when I run manually by calling java ......cli.Main in Windows platform . Kindly advise thanks !

       
    • Boromir

      Boromir - 2005-10-12

      I think you are receiving this error when calling the fullsync.sh script.
      To get this running I had to define the JAVA_HOME variable, because the script isn't able to find the correct location.
      So I defined it in the fullsync.sh script after #!/bin/sh
      JAVA_HOME=/usr/lib/j2sdk1.5-sun

      Maybe this will solve your problem.
      PS: I use Debian Sarge

       
    • gimped

      gimped - 2006-07-21

      i get the same error after I run this command
      # java -jar FullSyncInstaller.jar

      The error is below, how do I get passed it?

      ---
      Exception in thread "main" java.awt.AWTError: Cannot load AWT toolkit: gnu.java.awt.peer.gtk.GtkToolkit
         at java.awt.Toolkit.getDefaultToolkit(libgcj.so.7)
         at java.awt.Font.tk(libgcj.so.7)
         at java.awt.Font.getPeerFromToolkit(libgcj.so.7)
         at java.awt.Font.<init>(libgcj.so.7)
         at javax.swing.plaf.FontUIResource.<init>(libgcj.so.7)
         at javax.swing.plaf.metal.DefaultMetalTheme.<clinit>(libgcj.so.7)
         at java.lang.Class.initializeClass(libgcj.so.7)
         at javax.swing.plaf.metal.MetalLookAndFeel.createDefaultTheme(libgcj.so.7)
         at javax.swing.plaf.metal.MetalLookAndFeel.<init>(libgcj.so.7)
         at javax.swing.UIManager.<clinit>(libgcj.so.7)
         at java.lang.Class.initializeClass(libgcj.so.7)
         at com.izforge.izpack.installer.GUIInstaller.loadLookAndFeel(Unknown Source)
         at com.izforge.izpack.installer.GUIInstaller.<init>(Unknown Source)
         at java.lang.Class.newInstance(libgcj.so.7)
         at com.izforge.izpack.installer.Installer.main(Unknown Source)
      Caused by: java.lang.ClassNotFoundException: gnu.java.awt.peer.gtk.GtkToolkit
         at java.lang.Class.forName(libgcj.so.7)
         at java.lang.Class.forName(libgcj.so.7)
         at java.awt.Toolkit.getDefaultToolkit(libgcj.so.7)
         ...14 more

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks