FullSync on Mac OS 64 bit

  • Anonymous - 2011-10-30

    I think fullsync is still the best solution to me to sync stuffs via FTP or between different computers
    I just got a mac and unfortunately i can't run fullsync on it (Mac os Lion)

    JAVA_HOME is specified and fullsync.sh return no error, but fullsync doesnt start, i just get the normal echoed line  :

    FULLSYNC_HOME = /Applications/FullSync

    then a new shell prompt. Nothing particular in logs as well.
    I guess it has something to do with the 64bit java machine … because the same error (with no error msg) occurs when using the 64bit java machine on linux. Linux users have to install and use the 32 bit version.

    So i tried to force 32bit machine : in the java settings (application > Utilities > Java settings (or sthg similar, my os is not english) i dropped the 32 bit version in first, i also added "-d32" option on the last line in the fullsync.sh but i had no success

    does anyone know a way to force the use of a 32 bit version of java, or do you think this error has nothing to do with 32/64bit ?

  • Christoph

    Christoph - 2011-11-05

    Hi kro,

    the last released version of FullSync does not support 64bit operating systems (aka java vms) or MacOS.
    The SWT libraries required for that are just not included.

    you could however try the current trunk version of it (if you can build it from the source)

    The next version of FullSync will include support for 64bit linux and Mac operating systems.
    I do not have access to a machine running MacOS thus I cannot test for that.

    HTH cobexer


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks