Mac OSX: Doesn't work.

Help
Anonymous
2007-04-19
2013-05-07
1 2 3 > >> (Page 1 of 3)
  • Anonymous - 2007-04-19

    I know that the newest version for Mac isn't out yet, so I decided to go ahead and try the older versions. None of them work for me -- they both end up with the same result, which is that the screen mode changes and fades to black, but then nothing happens. The oldest version crashes after having the black screen show for a while, and the newer version just stays black until I hit Escape a couple times. I know that the newest version for Mac might fix this issue, but I don't know that for sure. I just thought I'd mention it.

     
    • Keith Brown

      Keith Brown - 2007-05-01

      On the last of the 1.1x line, you need to do a change before it will run.

      Right Click/Control Click on the package, goto Show Package Contents, then goto Contents/Resources/Data/ and delete/rename default.ttf. Next, in a separate finder window, goto /Library/Fonts/ (ya know, the Library at the root of your hard drive), and copy Chalkboard.ttf. Next, goto the window showing the contents of FoF, and paste the font. Rename Chalkboard.ttf to default.ttf. It should run now.

      However, on the 1.2 branch, this doesn't seem to work. Some people have made reports of replacing /Contents/Resources/lib/ with that from the last 1.1 release, and getting it to work. I personally have done that, and I can

       
      • Alex Flanagan

        Alex Flanagan - 2007-07-26

        I just got the 1.2.451 build working on my iBook G4 using the following steps (with thanks to Keith):

        1) Download version 1.2.451, uncompress and drop the .app into your Applications folder.

        2) Right (or ctrl-) click on Frets On Fire.app in your Applications folder and select Show Package Contents.

        2) Download version 1.1.324, uncompress on your Desktop.

        3) Right (or ctrl-) click on Frets On Fire.app on your Desktop and select Show Package Contents.

        4) Within this second package contents folder (1.1.324, from your Desktop) open Contents/Resources/lib and copy the Python 2.4 folder to the same location in the 1.2.451 package (Contents/Resources/lib). When asked, select to "Replace" the files.

        (Note, I tried running the game at this point and it went from the "black screen until you quit" situation to the "black screen until it crashes" one.)

        5) Go to your Macintosh HD. Open Library/Fonts.

        6) Copy Chalkboard.ttf.

        7) Go to the 1.2.451 package contents window (that you just copied Python 2.4 into. Back out a folder (to Resources) and open the Data folder.

        8) Rename default.ttf to default.ttf.bak. Select "Use .bak" when prompted.

        9) Paste Chalkboard.ttf.

        10) Start the game.

        This is as far as I went. The main menu showed up and I assume it works from this point.

         
    • guardian34

      guardian34 - 2007-07-25

      1.1.324 works for me, but 1.2.451 does not...

       
    • guardian34

      guardian34 - 2007-07-25

      Traceback (most recent call last):
        File "/Applications/Frets on Fire 1.2.451.app/Contents/Resources/__boot__.py", line 158, in ?
          _run('FretsOnFire.py')
        File "/Applications/Frets on Fire 1.2.451.app/Contents/Resources/__boot__.py", line 134, in _run
          execfile(path, globals(), globals())
        File "/Applications/Frets on Fire 1.2.451.app/Contents/Resources/FretsOnFire.py", line 64, in ?
          engine = GameEngine(config)
        File "GameEngine.pyo", line 166, in __init__
        File "Svg.pyo", line 77, in __init__
        File "Svg.pyo", line 240, in __init__
      AttributeError: 'module' object has no attribute 'GMatrix33'
      2007-07-24 23:38:13.870 Frets on Fire[15132] Frets on Fire Error
      2007-07-24 23:38:13.870 Frets on Fire[15132] Frets on Fire Error
      An unexpected error has occurred during execution of the main script

      AttributeError: 'module' object has no attribute 'GMatrix33'
      Frets on Fire(15132,0xa000d000) malloc: ***  Deallocation of a pointer not malloced: 0xda210e0; This could be a double free(), or free() called with the middle of an allocated block; Try setting environment variable MallocHelp to see tools to help debug

       
    • NiKoZSTeR

      NiKoZSTeR - 2007-08-01

      Alex made a Great job but the pakager of the new version 1.2.451 forgot other 2 files in the Contents/Resources/data/ folder :
      flame1.svg
      flame2.svg

      to fix it  same procedures as described from Alex:

      copy from the version  1.1.324 Contents/Resources/data/ folder to tel version 1.2.451 once.

      and there you go!!!!

       
    • guardian34

      guardian34 - 2007-08-04

      Thanks, that worked for me.

       
      • guardian34

        guardian34 - 2007-08-07

        However, the fret graphics don't look right...

         
    • DAVE

      DAVE - 2007-08-04

      I've followed the above instructions to a T, and while I no longer get the black screen, it still isn't working. It's going to a maroon screen with background music, but it's in a smaller window now instead of fullscreen, and nothing ever shows up. I've got an Intel MacBook Pro, if that makes any difference. I'm not sure what the deal is, but any help would be much appreciated.

       
    • Anonymous - 2007-08-07

      where would one download version 1.1.324 from?  thanks in advance ... the FoF web site is less than helpful

       
    • Anonymous - 2007-08-07

      found 1.1.324 and followed the above instructions exactly, including the extra step about the flame.svg files... no change.  please advise, thanks.

       
    • Jake

      Jake - 2007-08-11

      Can someone direct me to where I could DL version 1.1.324? Thanks

       
    • siriusfox

      siriusfox - 2007-08-13

      That fixed the crashing problem I was having, but the game still won't run for me. I get the maroon screen with music. No text, and pressing the arrow keys does not produce the menu sounds that it normally would.

      2GHz iMac Core Duo
      1GB RAM
      X1600 ATI Graphics

       
    • vampx

      vampx - 2007-08-15

      dont forget to rename Chalkboard.ttf file to default.tff
      works!

       
    • spectrex

      spectrex - 2007-08-21

      uh, the python2.4 folder contains all the game code. It might "work" if you copy it from an old version, but you'll get messed up graphics and no new features or bugfixes. The flame files are missing because they're not used in 1.2.451. Copying the whole data folder from the older version will fix it --- because it just turns the whole thing back into the old version!

      Copying just python2.4/lib-dynload/_amanith.so from an old, working version to 1.2.451 seems to make it work.

       
    • Willners

      Willners - 2007-09-10

      Hey!

      I cant get it work either. And yes, I have tried all these tutorials to make it work. Cant somebody upload Frets On Fire but modified so it works? Please please please!!! I have been trying to get this game forever! Looks so fun... Thanks

       
    • wbill584

      wbill584 - 2007-09-10

      @ willners

      Spectrex did describe exactly what is working

      so dowload the latest version, and install it on your intel-mac

      then download the previous version http://sourceforge.net/search/?type_of_search=files&group_id=182199&words=1.1.324
      and install this one also; to have the complete older package
      This version on itself will already work

      If you want the new one to work, ctrl-click on the old installed version and select show-package.
      copy the file _amanith.so that you find in going down in the following folders content/resources/lib/python2.4/lib-dynload.

      Now, ctrl-click on the new version and go down to the same folder and replace the _amanith.so file with the one you have copied on the desktop out the previous version. This should work just fine.

       
    • Willners

      Willners - 2007-09-11

      Nope...

      Didnt work at all... Maybe the Operating System is too old... I got 10.3.9. Is it?

       
    • Alex Yang-Nikodym

      OK, I got it to work, when none of the above did. And thanks to all the posts, which helped me out to figure out the bugs and whatnot. Please note that this is on a PPC Mac.

      Step 1. Download the latest version of FoF, and 1.1.324. There should be a link to 1.1.324 on this page somewhere.

      Step 2. Extract both, and go into the FoF.app (1.1.324). Now, go to Contents/Resources/lib/python2.4/lib-dynload and grab the _amanith.so . Put this in the new FoF, in the same location the older one was in. Say yes when asked to replace. Now, FoF will start up, but you'll get nothing but a blue screen and some music.

      Step 3. Rename default.ttf (found in Contents/Resources/data) to default.ttf.bak . Say "use .bak" when the pop-up comes up.

      Step 4. Grab Chalkboard.ttf (from Library/Fonts) and paste it into the new FoF (into Contents/Resources/data). Rename it to default.ttf

      Step 5. If the game still doesn't work, or is buggy or something, grab the flame.svgs (there should be two) from FoF 1.1.324 (Contents/Resources/data) and paste it into the new FoF, into the same location you found the .svgs.

      And now the game should work. Although when the game closes, there is some lag... Meh. I'm off to play. Someone should e-mail the developers this, if it works for more people than just me.

       
    • Keiko

      Keiko - 2007-09-15

      This worked well on my first generation iMac G5 20" (PPC)
      And it also worked for my miniMac (intel)
      Though Frets on fire crashes when I quit it.. But that doesn't really matter.
      Thanks for the help man :)

       
    • nEmoGrinder

      nEmoGrinder - 2007-09-29

      I did exactly as spectrex advised and got the game working perfectly.  I'm running a macbook intel core duo 2.0ghx with 2gb ram.  The game actually runs smoother than on my pc (which is running vista so that's probably the reason, since the game was developed on XP I assume).

      the game really has given me some respect for python, although i still think it's a horrible code to learn on since it is completely polymorphic and there contains little to no syntax. I haven't used it yet but will later this year, I usually use java which i prefer since it is like the C language but without memory management.  Maybe when I get more familiar with python I will look into why this fixes the game and figure out what is actually going on.

      keep jamming!

       
    • Willners

      Willners - 2007-10-12

      GRRRR!!!!   Alex, your tutorial didnt work either!!! Im so pissed! Whats wrong with my comp?

       
    • Chaosraiden

      Chaosraiden - 2007-10-17

      Just made an account to post this one message.

      I tried alex's tutorial and it didn't work

      BUT I added some mods which can be downloaded here:
      http://files.filefront.com/modszip/;8821329;/fileinfo.html

      and it worked for me, hopefully it does the same for you.

       
1 2 3 > >> (Page 1 of 3)

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks