Why no PowerPC support?

cerrax
2007-04-30
2013-05-07
  • cerrax

    cerrax - 2007-04-30

    As the unfortunate recipient of a Power PC G5 (four months later I could've gotten an Intel Mac). I am wondering why Frets on Fire doesn't work with PowerPC Macs. I want to play it so bad but the only computer I have that is capable of running it is my G5!

    Is there any way to get a PowerPC compatible version?

    Maybe I could even use a virtual PC program and then run it as a Windows app inside that Virtual PC?

    Thanks in advance if you can help me.

     
    • Sami Kyöstilä

      Sami Kyöstilä - 2007-04-30

      The game should by all means run on PPC, but it's been reported that a bug in one of the support libraries, probably PyGame/SDL, is causing a crash at startup or later in the game. Unfortunately none of us in the development team have a PPC Mac (or actually any sort of Mac), we can't debug this issue any further. We hope that someone with a PPC Mac could dig into the problem and see if could be fixed easily.

      - Sami

       
    • cerrax

      cerrax - 2007-04-30

      What kind of help. I have some (but very little) programming knowledge. Maybe we could work to gether to be abkle to get FoF to work with a Power PC. I have a version of FoF for Mac OS X, but when I start it up, it goes to a black screen and stays there. I have to force quit to get out of it.

       
    • cerrax

      cerrax - 2007-04-30

      I ran FoF through my Terminal and got this:

      Last login: Mon Apr 30 11:47:37 on console
      /Users/Home/Desktop/Frets\ on\ Fire.app/Contents/MacOS/Frets\ on\ Fire; exit
      Welcome to Darwin!
      Manderz-wuvin-Chikaz:~ Home$ /Users/Home/Desktop/Frets\ on\ Fire.app/Contents/MacOS/Frets\ on\ Fire; exit
      Traceback (most recent call last):
        File "/Users/Home/Desktop/Frets on Fire.app/Contents/Resources/__boot__.py", line 158, in ?
          _run('FretsOnFire.py')
        File "/Users/Home/Desktop/Frets on Fire.app/Contents/Resources/__boot__.py", line 134, in _run
          execfile(path, globals(), globals())
        File "/Users/Home/Desktop/Frets on Fire.app/Contents/Resources/FretsOnFire.py", line 64, in ?
          engine = GameEngine(config)
        File "GameEngine.pyc", line 165, in __init__
        File "Svg.pyc", line 77, in __init__
        File "Svg.pyc", line 240, in __init__
      AttributeError: 'module' object has no attribute 'GMatrix33'
      2007-04-30 13:18:20.871 Frets on Fire[353] Frets on Fire Error
      2007-04-30 13:18:20.872 Frets on Fire[353] Frets on Fire Error
      An unexpected error has occurred during execution of the main script

      AttributeError: 'module' object has no attribute 'GMatrix33'
      Killed
      logout
      [Process completed]

       
    • cerrax

      cerrax - 2007-04-30

      I am really serious about this and I hope we can work together to get this to work. Any alterations you need done to files I can do in Terminal and/or TextEdit. My email is ckoch@cerrax.com. My AIM is cerrax3.

       
    • Keith Brown

      Keith Brown - 2007-05-01

      On the last of the 1.1x line, you need to do a change before it will run.

      Right Click/Control Click on the package, goto Show Package Contents, then goto Contents/Resources/Data/ and delete/rename default.ttf. Next, in a separate finder window, goto /Library/Fonts/ (ya know, the Library at the root of your hard drive), and copy Chalkboard.ttf. Next, goto the window showing the contents of FoF, and paste the font. Rename Chalkboard.ttf to default.ttf. It should run now.

      However, on the 1.2 branch, this doesn't seem to work. Some people have made reports of replacing /Contents/Resources/lib/ with that from the last 1.1 release, and getting it to work. I personally have done that, and I can get it to start, however, starting a song, or saving settings, seem to make it crash.

      And now, that there doesn't seem to be a current OSX release, we're kinda out of luck. The mac users get no lovin'.

       
    • CoCoLUS

      CoCoLUS - 2007-05-18

      I tried the newest binary release (1.2.451), and I'm experiencing the same problem as described, black screen and the 'GMatrix33' error message. Its an Intel Mac, though, using Mac OS X 10.4.9.

      Any ideas?

       
    • SPManiac

      SPManiac - 2007-05-19

      As I posted in the version related threrad, I investigated a little bit and found that if you replace the file _amanith.so in /Frets\ on\ Fire.app/Contents/Resources/lib/python2.4/lib-dynload/ wiht the one from the last working release (1.1.3.4 in my case) the game will run, but without the discolights in the backround which still work in the PC version.
      But there exist some problems with GH2 songs, that worked in the older release...

       
    • lemoncurry

      lemoncurry - 2008-04-24

      I found this on another thread and it works with my iMac G4-800mzh

      go to http://tgaragemedia.com/downloads and click on "Frets on Fire" download link.

       

Log in to post a comment.