Adding a FreePlane map to WordPress page/post

2011-05-14
2012-10-07
  • thehumbletester

    thehumbletester - 2011-05-14

    It would be very useful to be able to display FreePlane maps in a WordPress
    blog post with the ability to expand and collapse the nodes. Has anybody
    actually managed to do this?

    I have tried to export a FreePlane map to a Java applet using the FreePlane
    export to Java Applet function in FreePlane (version 1.1.3) and to include the
    exported java applet in a WordPress (version 3.1.2) post as outlined below.
    The java applet does run properly when directly using the HTML page produced
    by FreePlane, but does not run when the applet tag is entered into a WordPress
    post. When running the applet in the WordPress post the java virtual machine
    starts and produces the error "load: class
    org.freeplane.main.applet.FreeplaneApplet.class not found." (see below). I
    realize that the java virtual machine cannot find the FreeplaneApplet.class
    which means that it cannot find the freeplaneviewer.jar file and that this is
    an issue with the way that the location of the freeplaneviewer.jar file is
    being specified in the applet tag. Apparently WordPress has some specific
    requirements on how the directory locations are specified and I have not
    managed to specify this correctly. So I am hoping that somebody has already
    solved this problem.

    Both the freeplaneviewer.jar and map.mm files were uploaded to the javatest
    directory on the web server. The web server is running Apache/2.2.17, and PHP
    Version 5.2.17. (Note that "myhomedirectory" below is not the real directory
    for obvious reasons.).

    Thanks
    thehumbletester

    HTML entered in Wordpress post:
    <applet code="org.freeplane.main.applet.FreeplaneApplet.class" archive="/myhomedirectory/public_html/javatest/freeplaneviewer.jar" width="600" height="400"><param name="type" value="application/x-java- applet;version=1.5"/><param name="scriptable" value="false"/><param name="browsemode_initial_map" value="/myhomedirectory/public_html/javatest/map.mm"/><param name="selection_method" value="selection_method_direct"/>

    Error Details:

    Java Plug-in 1.6.0_24
    Using JRE version 1.6.0_24-b07 Java HotSpot(TM) Client VM

    load: class org.freeplane.main.applet.FreeplaneApplet.class not found.
    java.lang.ClassNotFoundException:
    org.freeplane.main.applet.FreeplaneApplet.class
    at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)
    at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Unknown Source)
    at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
    at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Unknown Source)
    at sun.plugin2.applet.Plugin2Manager.createApplet(Unknown Source)
    at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown
    Source)
    at java.lang.Thread.run(Unknown Source)
    Exception: java.lang.ClassNotFoundException:
    org.freeplane.main.applet.FreeplaneApplet.class

     
  • Terry Britton

    Terry Britton - 2012-03-29

    Has this ever been resolved? I had the map working one day, but is not working
    now. WP 3.3.1

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks