#547 Built fine with boost 1.54, fails fecause it does not find 1.52

Latest Subversion
closed-invalid
nobody
None
5
2014-01-10
2013-10-17
No

/usr/bin/freeorion.elf: error while loading shared libraries: libboost_filesyutem.so.1.52.0: cannot open shared object file: No such file or directory

There is no such a file in the computer where successfully built the game :(

Discussion

  • Geoff Topping

    Geoff Topping - 2013-10-26

    I would guess that some dependency you've included in the build depends on boost 1.52 then. I don't think anything in the FreeOrion build system itself explicitly adds a dependency, but if you're using binaries of a dependency - most likely Ogre3D - that depend on 1.52, then that would show up in the FreeOrion binary as well.

     
  • Adrián Chaves Fernández

    Thanks! It was not Ogre but it was indeed a dependency: GiGi. It seems I had built it before the boost upgrade. So, I rebuilt GiGi, rebuild FreeOrion against it, and this is what I’m getting now:

    [gallaecio@castelao local]$ freeorion
    /usr/share/freeorion
    /usr/bin/freeorion.elf: symbol lookup error: /usr/bin/freeorion.elf: undefined symbol: _ZN2GG10SubTextureC1ERKN5boost10shared_ptrIKNS_7TextureEEE

    I see it is still boost-related. Any hints of what I might be missing?

     
    Last edit: Adrián Chaves Fernández 2013-11-21
  • Geoff Topping

    Geoff Topping - 2014-01-10
    • status: open --> closed-invalid
     
  • Geoff Topping

    Geoff Topping - 2014-01-10

    You'd best ask about this on the forums, or search for similar error messages on google. Something didn't link properly, but I can't help with that.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks