#303 Savegames not working

Latest Subversion
closed-fixed
nobody
None
8
2007-08-24
2007-07-28
No

In current revision 2200 on linux, sometimes the savegames do not contain any queue-orders.

If you select some buildings or researches - all will be lost if the game is saved and loaded.

I tried it about five times:
- after every NEW game, it ALWAYS happens that the queues are empty after reloading a game saved in Turn1
- if saving after Turn1 occurs, it mostly works.

I am sorry that i cannot figure out more circumstances.

Discussion

  • Geoff Topping

    Geoff Topping - 2007-07-28

    Logged In: YES
    user_id=913462
    Originator: NO

    I get similar errors with this procedure:
    -Start FreeOrion
    -Start new single player game
    -Save game
    -Load game just saved
    -Menu bar at top is gone, and fleets and planets can't be given orders

    Loading the same save file from the splash menu screen works fine.

    However, fleet move orders given after the start of a turn but before saving are lost. New fleet orders, by drag-drop, seem to be retained in the save.

     
  • Geoff Topping

    Geoff Topping - 2007-07-28
    • priority: 5 --> 8
     
  • Zach Laine

    Zach Laine - 2007-08-24

    Logged In: YES
    user_id=729903
    Originator: NO

    Fixed in Subversion.

     
  • Zach Laine

    Zach Laine - 2007-08-24
    • status: open --> closed-fixed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks