#374 lighthttpd won't run after reboot

v0.69x
closed
WebGUI (143)
5
2012-10-28
2008-05-13
No

Default configuration is fine, but after saving settings and reboot- lighthttp isn't running. I've tried manually restarting it, but that doesn't work. Not seeing anything in the /var/log directory that might indicate what the problem might be.

Discussion

  • Volker

    Volker - 2008-05-14

    Logged In: YES
    user_id=1598685
    Originator: NO

    What settings are you changing? WebGUI related or webserver?
    Please describe a workflow to let me reproduce this error.

    Regards
    Volker

     
  • Zinger da  Zinger

    Logged In: YES
    user_id=316903
    Originator: YES

    This is the WebGUI. I've tried two ways, which lead to the same thing:
    1) Boot off new .69 CD with existing .68 config on USB stick.
    2) Boot off new .69 CD w/o config, manually adjust name, ip, raid, users, passwords, etc - but no modification from standard WebGUI settings.

    Both times FreeNAS boots up and runs, but the webgui isn't available - the service doesn't appear to be running and there's no response on ports 80 or 443.

    thanks for the help.

     
  • Volker

    Volker - 2008-05-19

    Logged In: YES
    user_id=1598685
    Originator: NO

    What is displayed if you try to manually try to start lighhtpd:

    /etc/rc.d/lighttpd restart

    Display log:

    nano /var/log/system.log

    Regards
    Volker

     
  • kiki

    kiki - 2008-05-21

    Logged In: YES
    user_id=2093766
    Originator: NO

    The same for me.
    I first try to update via img and update is apply but no WebGUI after reboot.
    I also install by cd, but after restoring config, no WebGUI
    All other service seems to work (ssh and daily email report for me).

    When I use command : "/etc/rc.d/lighttpd restart"
    I receive following message in console :

    Performing sanity check on lighttpd configuration:
    Syntax OK
    lighttpd not running? (check /var/run/lighttpd.pid).

    But no more line are added in /var/log/system.log.

    Regards

     
  • Volker

    Volker - 2008-05-21

    Logged In: YES
    user_id=1598685
    Originator: NO

    What about

    /etc/rc.d/lighttpd start

    Regards
    Volker

     
  • SourceForge Robot

    Logged In: YES
    user_id=1312539
    Originator: NO

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     

Log in to post a comment.