#119 Format disk Geom mirror fails "Invalid argument"

v0.671
closed
5
2012-10-28
2006-08-25
Paul Smith
No

Using a recycled Maxtor NAS 4300. Have reflashed the
BIOS, so it believes it is a standard Supermicro
motherboard.

3 Internal Drives.
1 with System, trying to add other 2 drives as a
mirror.

Drives will format correctly as UFS with Soft Updates,
will not format as "Software RAID:Geom mirror"

Disk Initialization details as follows:

640+0 records in
640+0 records out
20971520 bytes transferred in 0.541109 secs (38756548
bytes/sec)
fdisk: invalid fdisk partition table found
fdisk: Geom not found
* Working on device /dev/ad2 *
"fdisk: Geom not found"is not an error message!
16+0 records in
16+0 records out
524288 bytes transferred in 0.012693 secs (41305520
bytes/sec)
Can't clear metadata on /dev/ad2: Invalid argument.
Not fully done.

This error also occurs if I try to do the same
operation on /dev/ad3

Discussion

  • Olivier Cochard-Labbe

    Logged In: YES
    user_id=1370551
    Originator: NO

    Do you have still this problem?

     
  • Paul Smith

    Paul Smith - 2007-01-09

    Logged In: YES
    user_id=1583713
    Originator: YES

    This has been outstanding a while 8-)!
    I have since stopped looking at FreeNAS for my solution, and have purchased a small RAID system. I still have the Maxtor unit in it's original configuration (with this problem) if you wish to pursue this further. I can load the latest version of FreeNAS and try again if you wish to try to find more about this problem, but it is very much a background task for me now.

     
  • Olivier Cochard-Labbe

    Logged In: YES
    user_id=1370551
    Originator: NO

    No, it's ok.
    Thanks for your update.

     

Log in to post a comment.